Yesterday my external HDD and Time Machine started acting strangely, and I hope you can help me with this. When trying to make a backup, at first my external HDD took a very long time to clean up old backups. In the end Time Machine told me there was no room for new backups after all. Then, when I tried to remove the external disk this also took a long time, and since no backup was made I decided to unplug it after ~15 minutes.

When I tried again today, I noticed several things:

  • Time Machine gave me a different message: 'an error has occurred while creating the backup directory.'
  • There is a file with a name that ends in '.inProgress' in my ext-HDD > Backups.backupdb > MyMacbookPro folder. I cannot do anything with this file (e.g. erase or rename it.)
  • When I tell Time Machine to create a backup, I get these two messages in my console:

    Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/Time Machine/Backups.backupdb/MacBook Pro van Fabian size:37
    
    Backup failed with error 2: 2
    

Could someone tell me what I can do to make my backup drive usable again?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.