I am trying to run a 32 bit OS (Android x86) in VMware Player. It is coming up with the error 'VT-x is not available', even though I have a 64 bit CPU/host OS. Why is this?

I am aware that you cannot virtualise a 64 bit OS inside a 64 bit OS without VT-x, but I assumed this would not be the case for 32 bit. How might I solve this, am I missing a detail here? The CPU I am using is an Intel Pentium p6200, which does not support VT-x. I do not have the option of VT-x. Am I still able to virtualise 32 bit OSes?

I am considering using software virtualisation, such as QEMU, but I would prefer not to because of the slowdown involved.

  • 1
    Depending on how the VM is set up, it may require VT-x. Check its configuration. I’m not sure if VMware Player shows all the relevant options. – Daniel B May 28 '18 at 9:27
  • I've tried that. You can change very little, although i have tried changing 'virtualise Intel VT-x' on and off, but i believe that is for the vm's CPU, and will not affect the problem – flumperious May 28 '18 at 9:36
  • 1
    I’d like to check the .vmx file of your VM. How did you create it? – Daniel B May 28 '18 at 9:46
  • Possible duplicate of VT-x is not available, but is enabled in BIOS – phuclv May 28 '18 at 9:49
  • @DanielB i created it through player, using the default options. There doesn't seem to be anywhere to change, view or specify the OS or CPU bits for the vm in player. I could try pro. – flumperious May 28 '18 at 10:05

Remove from the .vmx file the following lines:

  • vvtd.enable = "TRUE"
  • vhv.enable = "TRUE"

It may then work. It could result in abysmal performance and/or crashes, too.

I suggest using an advanced editor like Notepad++ to edit the file. You can also use WordPad.


The following lines are also relevant (though not present in this case):

  • monitor.virtual_mmu = "software"
  • monitor.virtual_exec = "software"

The value can be either software, hardware or automatic. automatic is the default value.

In VMware Workstation 12, I have the following options:

enter image description here

The mode dropdown has the following options, which result in the following virtual_exec/virtual_mmu values:

  • “Automatic”: automatic/automatic
  • “Binary translation”: software/software
  • “Intel VT-x or AMD-V”: hardware/software
  • “Intel VT-x/EPT or AMD-V/RVI”: hardware/hardware

Additionally, the checkboxes toggle the following options:

  • “Disable acceleration for binary translation”: disable_acceleration = "TRUE"
  • “Virtualize Intel VT-x/EPT or AMD-V/RVI”: vhv.enable = "TRUE"
  • “Virtualize CPU performance counters”: vpmc.enable = "TRUE"

Except disabling acceleration, all options require CPU support.

Because VMware Player does not offer access to all options it supports, you need to edit the .vmx file manually. It’s a regular text file, though it may not have Windows line breaks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.