I got W7x64 guest. While my host was also W7x64 -everything works fine. But when I've changed host OS to Win10x64 I got problems. Now my guest works extremely slow. How that could be fixed? I've already tried increasing memory and give my guest all cores - that doesnt help.

VirtualBox 5.1.32

  • You should never suffocate your host by giving to the guest. Is your host upgraded to Windows 10, or a clean install?
    – Kinnectus
    May 29, 2018 at 7:43
  • Check the memory usage of other programs in Windows 10 like automatic services, background task, all UWP apps etc. Also update the virtual box.
    – Biswapriyo
    May 29, 2018 at 8:08
  • @Kinnectus it is fresh install
    – Seekeer
    May 29, 2018 at 11:59
  • @Biswapriyo I got plenty of free memory and processor power when VB is not running.
    – Seekeer
    May 29, 2018 at 11:59

4 Answers 4


I had similar issues as my host machine (OSX) was a bit wimpy. It is a dual core early 2009 Mac Mini with 8GB Ram.

A Win10 x64 guest was slow as hell. I changed the guest settings to:

  • 1 CPU
  • 3072MB RAM
  • 192MB Video Memory
  • 2D & 3D Video Acceleration enabled
  • Use unscaled HiDPI output enabled

That made a big difference - I was stressing the host out with too much CPU and RAM allocated to the guest. It's still a bit slow, but is a lot better.

Hope this helps.

  • What where your previous settings?
    – golimar
    Dec 5, 2019 at 13:56
  • 1
    Didn't have HiDPI output, but made the other changes on my win10 host for the win10 guest and it did improve...
    – Malachi
    Aug 19, 2020 at 15:42
  • made my experience worse, CPU struggled at 1 CPU Oct 28, 2020 at 15:05

How much RAM does your host have and how much RAM is allocated to your guest in VirtualBox? For example, if your system has 4GB RAM, you will always need minimally 2GB RAM for your host to properly run the virtual machine.

Windows 10 is known for not being efficient with RAM. A lot of background tasks (a lot more than Windows 7) require a heavy portion of your RAM. Spreading your RAM evenly over your host and your guest disregards the fact that Windows 10 needs a lot more RAM. If you don't have enough RAM for your host, the VirtualBox application will run slower (which has nothing to do with your guest). Try to give your guest some less RAM (1GB if you have 4GB in total, 1GB or 2GB if you have 8GB in total, ...). You can do that at Settings->System and move the slider at base memory.

TL;DR: Decrease the allocated RAM for your guest in VirtualBox.

  • 1
    This makes no sense... Microsoft minimum specs for Windows 10 x64 is 2GB RAM.... The moment you install a hyperviser and get a guest running you're eating into your host's minimum recommended memory... one should expect performance problems and instability. Your answer should have been comments questioning the user's current configuration before assuming memory. The user may have an 8GB+ host for all we know...
    – Kinnectus
    May 29, 2018 at 13:09
  • I cannot comment yet (don't have enough reputation), but I believe you're missing the point (or maybe I misunderstood you). My guess is that he gave too much RAM to the guest, and not enough to the host that runs the VM. Yes, 2GB RAM is the minimum necessary to run Windows 10 x64, but to run some programs (and a virtual machine is heavy to run), you need more than 2GB for it to run properly. And if he has more than 8GB (16GM RAM for example), he can drop the RAM for the guest to 4GB for example.
    – marijnr
    May 29, 2018 at 13:17
  • I got 16 GB on host, 4 of it is used by guest. So it is not about memory.
    – Seekeer
    May 29, 2018 at 22:06
  • And how many of your processor cores do you have on your host/are allocated to the guest?
    – marijnr
    May 30, 2018 at 7:22
  • 1
    would be great if the authors provided some benchmarking data so we could possibly compare it and see if it's the problem with resources with host, or its the problem with guest system (i dont know fragmentation) Jul 21, 2020 at 14:48

I had the same issue today. It was not possible to even load Windows 10 x64 in 10 minutes.
I solved it in this way:

My settings:

  • RAM 4000 MB
  • Chipset: default changed to ICH9
  • Processors: 1 CPU
  • Graphics Controller: VBoxVGA without enabling 3D acceleration (you will have a warning)
  • Video memory: 128 MB

PS. I know the question is old, but just leave it for the next generations :)


Assuming the host is a fresh install but the guest is not, I would first uninstall the Guest Additions, update both VirtualBox and Guest Additions and then reinstall the additions. This generally fixed similar issues I have had. The main realization is that guest performance is significantly impacted by the guest additions and that when a new operating system version is released, changes eventually get made to the additions to better support the new release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.