2

I would like to troubleshoot my inability to import photos from iPhone to Windows 10. I am an advanced user struggling to find relevant help on the internet since most results are unusable masked adverts for paid third party software.

I want to use it the following way

  1. connect iPhone via USB to my Windows 10 PC
  2. open Microsoft "Photos" app
  3. click in the upper right on import > add from the device over USB
  4. select all photos and click import

4th step is where it fails, with no usable message.

  • I have set the device as trusted on iPhone
  • I mostly don't see it in My Computer, therefore I cannot just copy
  • I tried uninstalling every driver and iTunes software
  • Despite not being visible in Windows Explorer, iTunes can always access the contents with no issue
  • it has a tiny moments when it starts working, but overall import fails sooner or later and never copies all 3k photos. Mostly MSPhotos don't show any content, just failure message, sometimes it shows it's content and acts as I can select what to import, but as described fails sooner or later
  • iTunes can successfully copy entire phone.

    Other attempts

  • I tried multiple free 3rd party SW, all of them either failed or seemed like to be usable only after buying their extended version
  • I tried using iTunes for Syncing the Photos
    • I maybe don't know how to use it, or it is faulty too. But I've set the directory where my Photos should be synced, but sync seems to just backup the phone and creates tiny 'Photo Database file', but no photo actually gets copied onto PC.
  • My main goal with this is actually confirming that there is a global issue with current versions of SW involved, which would be the best option – Javo May 29 '18 at 13:15
0

I could not get my iPhone to appear in Windows Explorer.

The fix for me was to turn off iCloud Photo Library on my phone in Settings - Photos.

After doing that, and then reconnecting iPhone, it appeared in windows explorer as an icon under My PC. I was able to right click and select “Import Photos”.

Perhaps the iCloud Photo Library feature of having some full size and some low res thumbnails on your phone confuses the windows driver. Don’t know, but fix worked for me.

  • Has this happened on Win10? – Javo May 30 '18 at 8:10
  • @Javo It was Windows 8. Sorry. Forgot you were specifically Win 10. – John Rees May 30 '18 at 9:17
  • No problem Mr. Rees :) I have iCloud photo library off, since I have only 5gb free space and over 30gb photos/vids, which prevents me from turning it on – Javo May 30 '18 at 10:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.