0

My Motherboard/BIOS doesn't detect USB devices (Mouse, Keyboard) when I cold boot my computer (booting after complete shutdown). BIOS is always showing me 0 Keyboard / 0 Mouse / 2 USB Hosts connected. If I press the reset button at that point, my computer reboots and BIOS will recognize all devices. Fastboot is OFF.

This means that I have to press the reset button on my computer after every cold boot. I can't figure out what's causing this

  • If I don't press the reset button during first boot and let my PC continue to boot with 0 Mouse / 0 Keyboard detected, they will NOT be detected by the operating system either (Ubuntu, Windows 10, Hackintosh).
  • BIOS recognizes that 2 USB Hosts are connected (front panel USB Ports on my Case)
  • The LEDs of my Keyboard and Mouse stay off when they are not detected by BIOS (they don't get any power at all).
  • The problem persists regardless of which Keyboard, Mouse or USB Port I use (Apple Keyboard, WASD Keyboard, Corsair K65 Keyboard, Logitech MX 518 & G502 Mouse)

I'm using the following BIOS Settings potentially relevant to USB:

  • Fastboot: Disabled

  • POST Report: 5 Sec

  • Boot up NumLock State: Enabled
  • Interrupt 19 Capture
  • Legacy USB Support: AUTO
  • Intel xHCI Mode: Smart Auto
  • EHCI Hand-off: Disabled
  • Launch CSM: Enabled
  • Boot device control: UEFI and Legacy OPROM
  • Boot from storage devices: Legacy OPROM first

Hardware: Asus Maximus VII Hero (Z97, BIOS Version 3201 x64), Intel 4790K, 32GB RAM, GTX 1080

  • In most cases I have seen you had to mess about with the Intel xHCI Mode and the EHCI Hand-off. Some combinations just don't work. Be advised that changing these may affect how your OS detects the USB devices. – Tonny May 30 '18 at 13:48
  • Thanks, I think I solved my problem following your comment (see my Answer below). I think this was caused by a combination of things, namely EHCI Hand-off, but also Auto settings not working as they should. Lesson learned: don't trust "Auto settings. – karlo_asm May 30 '18 at 15:38
1

OK I think I've found a solution following Tonnys comment. Hopefully this will help someone with the same issue. Read carefully so you don't have to reset your CMOS like I had to.

  1. I had to set EHCI Hand-off to Enabled,
  2. This is important: I also needed to change Legacy USB Support from Auto to Enabled.

I left Legacy USB Support set to Auto first, which caused my Motherboard to not detect USB Devices during boot AT ALL (not even after reset) and I was locked out of BIOS completely. I guess Auto doesn't work as it should. I had to clear my CMOS in order to be able to get back into BIOS.

  • Good job! If I remember correctly: EHCI Hand-off is a requirement for USB Legacy to work correctly. Some Bios will silently enable EHCI hand-off if USB legacy support is needed, while others need both settings to be explicitly set. – Tonny May 30 '18 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.