It looks like an update was installed on our server which has “broken” our RDP access.

The server are physical servers so how can we resolve the issue as we can't RDP the server. The servers are Windows 2012 R2 servers

There's way to fix this issue as describe in KB4093492.

Basically have both client and server fully patch, and if that's not possible update the client computer's registry with this value:

Registry path : HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters

Value : AllowEncryptionOracle

Date type : DWORD

If you want a quick fix and you are within secured intranet, you can use this on the server side:

  1. Logon to Windows Server as a local administrator and open Server Manager from the desktop Task Bar or Start Screen.

  2. In the left pane of Server Manager, click Local Server. Wait a few seconds for the information about the local server to update in the right pane. In the Properties section of the right pane you should see the status of Remote Desktop, which is disabled by default.

  3. Click on the status to change it to Enabled. The Systems Properties dialog opens on the Remote tab. Under Remote Desktop in the Systems Properties dialog, select Allow remote connections to this computer. Ucheck the Allow connections only from computers running Remote Desktop with Network Level Authentication (recommended) checkbox. So you will be using less secure non-recommended setting. Then click OK.

RDP

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.