0

usually this is a simple task for ffmpeg but i have this link:

https://nana10-hdv-uk-sw.ctedgecdn.net/Nana10-Vod/_definst_/amlst:mediaroot/nana10/media/iiscdn/2018/04/kvarnitim230418_,500,700,1000,1400,1800,.mp4/playlist.m3u8?btoken=26b11ccee70374a261182857501b7fa673123f13f75735f97a2abfa6052dd060&str=1527695859&exp=1527697059

and i am trying to download it to my computer using this simple line:

ffmpeg -i input -c copy output.mp4

However it doesn't succeed and stuck although VLC player can load it up with no problem.

MacBook-Pro:downloads$ ffmpeg -i https://nana10-hdv-uk-sw.ctedgecdn.net/Nana10-Vod/_definst_/amlst:mediaroot/nana10/media/iiscdn/2018/04/kvarnitim230418_,500,700,1000,1400,1800,.mp4/playlist.m3u8?btoken=26b11ccee70374a261182857501b7fa673123f13f75735f97a2abfa6052dd060&str=1527695859&exp=1527697059 -c copy b.mp4
[3] 14301
[4] 14302
-bash: -c: command not found
[4]   Done                    str=1527695859
MacBook-Pro:downloads$ ffmpeg version 4.0 Copyright (c) 2000-2018 the FFmpeg developers
  built with Apple LLVM version 9.0.0 (clang-900.0.39.2)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/4.0 --enable-shared --enable-pthreads --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags=-I/System/Library/Frameworks/JavaVM.framework/Versions/Current/Headers/ --host-ldflags= --enable-gpl --enable-chromaprint --enable-ffplay --enable-frei0r --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfdk-aac --enable-libfontconfig --enable-libfreetype --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopus --enable-librsvg --enable-librtmp --enable-librubberband --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtesseract --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzimg --enable-libzmq --enable-opencl --enable-videotoolbox --enable-openssl --enable-lzma --enable-libopenjpeg --disable-decoder=jpeg2000 --extra-cflags=-I/usr/local/Cellar/openjpeg/2.3.0/include/openjpeg-2.3 --enable-nonfree
  libavutil      56. 14.100 / 56. 14.100
  libavcodec     58. 18.100 / 58. 18.100
  libavformat    58. 12.100 / 58. 12.100
  libavdevice    58.  3.100 / 58.  3.100
  libavfilter     7. 16.100 /  7. 16.100
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  1.100 /  5.  1.100
  libswresample   3.  1.100 /  3.  1.100
  libpostproc    55.  1.100 / 55.  1.100

I think this is related to the way the link is read because it has "." that makes ffmpeg probably read it as a file and thinking the rest of the line is a command.

3

OK i have found the solution for my problem. i just need to put " before the link and after it and then ffmpeg knows where the link is finished.

ffmpeg -i "https://nana10-hdv-uk-sw.ctedgecdn.net/Nana10-Vod/_definst_/amlst:mediaroot/nana10/media/iiscdn/2018/04/kvarnitim230418_,500,700,1000,1400,1800,.mp4/playlist.m3u8?btoken=26b11ccee70374a261182857501b7fa673123f13f75735f97a2abfa6052dd060&str=1527695859&exp=1527697059" -c copy b.mp4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.