1

I am trying to install FreeDOS onto a 16Gb SANDISK CF card booting from a USB stick.

The system BIOS is set to autodetect and shows the CF card as a 16Gb HDD. However when I boot the FreeDOS installer even with FAT32 enabled FDISK shows only a 8025Mb drive. I have tried both "Large" and "LBA" addressing modes.

If I add a primary partition (I have tried the full 8025Mb and 250Mb partition sizes) the installer appears to quickformat correctly but then gives this error:

DOS Area: unknown command given to driver

What am I doing wrong?

0

8025Mb is the DOS FDISK LBA limit. Notes on DOS FDISK Command

Some Considerations for Large Drives

DOS 6.22 FDISK

Does not support drives over 8.4GB. Will show total drive size for drives over 8.4GB as 7553MB or 8025MB or some similar value which will vary depending on how the drive is being handled by the BIOS.

I used Gparted to create a partition utilising the whole disk and then the FreeDOS installation went ahead smoothly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.