1

I don't get the autocomplete suggestions anymore in PowerShell. In the shell itself I only get a weird little dot where the suggestion should be and when I hit CTRL - spacebar in the script pane in PowerShell ISE I get an error saying "An unexpected issue has occured, and Windows PowerShell ISE must close." I've tried updating the help but that just gives me more errors.

A few months ago, PowerShell was working just fine so I assume it's since the latest update. Does anyone know how to fix this or safely reinstall PowerShell?

2

Download and install the Insiders edition of Powershell ISE. This is a known issue with ISE in Insider releases of Windows.

Duplicate of: https://stackoverflow.com/questions/49832619/powershell-ise-crash-on-ctrl-space/49846059#49846059

More info here: https://blogs.msdn.microsoft.com/powershell/2016/01/20/introducing-the-windows-powershell-ise-preview/

  • I didn't know there was a PowerShell ISE preview. I thought Microsoft decided to kill it in favor of Visual Studio Code. – user477799 May 31 '18 at 8:16
  • Thanks for your answer. I actually got it fixed by reinstalling PowerShell via Windows Components although I had tried that before and it hadn't fixed the issue the first time. – Jazzy_Daniels May 31 '18 at 8:34
0

Just curious. What OS are you running in order to make this statement.

fixed by reinstalling PowerShell via Windows Components

PoSH is part of the OS and delivered that way via the WMF installer (.Net Framework stuff). Legacy OS's have to download WMF installer to get the latest version.

On WIn10, the only PoSH component in the feature list is PoSH v2, which of course is depreciated and even MS says to disable it.

So, that's my curiosity, are you saying you just unchecked PoSH v2, restarted, rechecked v2 and restarted and all intelli-sense returned to normal?

BTW, only the popup list of inteli-sense does not display, tab complete still works. So, you can still get your snippets as well just by entering the unique name and hitting tab or enter.

BTW, this issue is not happening on all Win10 latest PoSH builds. Though it does happed on 1803/1809 (Win 10 spring update and some insider builds) and a few other versions.

The later OS insider builds do not exhibit this issue.

  • I'm on version 1803. I'm sorry about the statement "fixed by reinstalling", I know that's a bit to simplified. Nonetheless, yes that's what I did, just uncheck, restart and recheck and restart. And yes, I figured that PoSH v2 was depricated but I just wanted to give it a shot. I did have a cumulative update at the time I restarted for the first time but MS doesn't mention powershell anywhere so I don't think that's what fixed it. – Jazzy_Daniels Jun 1 '18 at 7:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.