0

I have downloaded codeblocks_17.12-1_amd64_stable.tar.xz and extracted it. But it creates a no .deb folder consist of many .deb files. I remember in previous version there was only one .deb file I could install it by dpkg -i x.deb command.

But how about this?

1

open a terminal in extracted directory and try these:

sudo dpkg -i ./*
sudo apt install -f
sudo apt --purge autoremove

and you can see CodeBlocks in your installed applications.

0

I tried this command and it worked:

sudo dpkg -i codeblocks-common_17.12-1_all.deb codeblocks-contrib-common_17.12-1_all.deb
0

The easiest would probably be to install it as Debian .deb binary package.

For downloading, follow instructions from here: (semiofficial code clocks binaries)

https://apt.jenslody.de/

Read on how to install a .deb package for example here:

Alternatively, you could build code::blocks from source which would probably preferrable if you feel comfortable building applications from source, or use a fedora/red-hat package. These possibilities are from here: http://www.codeblocks.org/downloads

0

This worked for me on Ubuntu 18.04.1:

sudo dpkg -i codeblocks_17.12-1_amd64.deb codeblocks-common_17.12-1_all.deb libcodeblocks0_17.12-1_amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.