0

Im trying to login with a user on a FTP server running VSFTPD on CentOS 7. When SELINUX is enforcing it always returns a 425 error: Unable to establish connection. All the necessary ports have been opened on the firewall and added onto selinux with semanage port. I have also enabled both the ftpd_connect_all_unreserved 1 and ftpd_full_access 1 setsebools.

If I change SELINUX to permissive mode I don't get any kinds of errors and all users log onto their specific ftp home folders.

This is my current vsftpd.conf, starting from the relevant user configurations:

...
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd/user_list
listen=NO
listen_ipv6=YES
allow_writeable_chroot=yes
pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES
listen_port=12121
ftp_data_port=45000-65535
userlist_enable=YES
userlist_deny=YES
userlist_file=/etc/vsftpd/bannedusers
local_root=/homesftp/$USER

This is the current situation regarding permissions on the users' ftp home folders, in desperation I have tried to enable every single permission, to no avail:

drwxrwxrwx. 2 user1 user1  6 May 29 23:37 user1
drwxrwxrwx. 4 user2 user2 89 May 29 21:27 user2
drwxrwxrwx. 3 user3 user3 17 May 29 23:27 user3

Also, here's the ls -Z output from the same ftp home folders for reference:

drwxrwxrwx. user1 user1 unconfined_u:object_r:default_t:s0 user1
drwxrwxrwx. user2 user2 unconfined_u:object_r:default_t:s0 user2
drwxrwxrwx. user3 user3 unconfined_u:object_r:default_t:s0 user3

I'm also trying to connect through active mode instead of passive, does that make a difference?

I also need to add that it's imperative that SELINUX remains enabled for this. Disabling it is just not an option for me at the moment.

Thanks in advance.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.