Is it possible to configure Notepad++ to stop checking for new versions each time it is run?

Every time Nodepad++ is started a dialog pops with:

An update package is available, do you want to download it?

migrated from stackoverflow.com Apr 20 '10 at 3:55

This question came from our site for professional and enthusiast programmers.

up vote 86 down vote accepted

Simply go to:

Settings -> Preferences -> Misc -> and deselect "Enable Notepad++ auto-updater"

  • 1
    @Apelsin It exists in Notepad++ 6.7.7 on Windows. – Andrew Morton May 17 '15 at 18:37
  • 3
    v6.9 has this feature, I just disable auto updates by following the steps provided in this answer. – gromit190 Mar 30 '16 at 6:24
  • 1
    @SimonD Chrome installs a service to do the auto-update as the browser runs with user credentials but the service runs with the required install privilege. I think every program installing a service to provide auto-update functionality is a bit of overkill and would prefer it in as few programs as possible. – Shiv Aug 2 '16 at 23:45
  • 1
    @Shiv, fair enough - we have different preferences here. We have notepad++ running on servers where users can't update so you get an annoying message every time you load it which you can't do anything about until IT fixes it. Making it non-modal would be a start. – Simon D Aug 4 '16 at 2:22
  • 2
    @SimonD I would say being able to roll Notepad++ out with the autoupdate feature turned off and pushing out updates via AD would be better. Autoupdate nag is really bad for a text editor - only web facing things like Flash or browsers should do it. – Shiv Aug 4 '16 at 5:02

You may also be looking to turn off plugin update checking, in which case go to:

Plugins -> Plugin Manager -> Show Plugin Manager -> Settings (bottom left), and deselect "Notify of plugin updates at startup".

  • 3
    God this has been bothering me so much, every gd time I open it. Thanks! – gakera Mar 10 '15 at 11:11
  • I swear, I love Notepad++ more than anything, it's the one app I miss most on Linux but this guy REALLY needs some UX help :D Thanks for showing me how to disable that!! – Toby J Mar 29 '17 at 13:57
  • UX is like 90% of Notepad++... – Andrew Dec 12 '17 at 13:00

In newer versions of Notepad++ the option to disable automatic updating no longer appears in the Options dialog.

You can simply rename the C:\Program Files\Notepad++\updater directory to stop this feature. (e.g. rename it to updater_disabled)

Credit to http://wpkg.org/Notepad_plus_plus for suggesting the solution.

  • 1
    Excellent! I used your answer to disable updates in a computer lab, looping through them with PsExec like so psexec \\lab315-%x cmd.exe /c ren "c:\Program Files (x86)\Notepad++\updater" "updater_disable" – ThisClark Jan 20 '15 at 19:12

Find and edit this file

C:\Users\\...User...\AppData\Roaming\Notepad++\config.xml

where ...User... is your username.

Find the line that reads something like this:

<GUIConfig name="noUpdate" intervalDays="15" nextUpdateDate="20141114">no</GUIConfig>

and change the 'no' to a 'yes'. In effect, you're telling Notepad++ that 'yes, you want no updates'.

Another line I've changed is this one:

<GUIConfig name="RememberLastSession">no</GUIConfig>

where I've changed the default 'yes' to a 'no'.

It infuriated me that Notepad++ opened pretty much evey file I'd ever opened, every time I started it, long after I'd lost any interest in any of those files.

I don't know why Notepad++ shows options in its preferences dialog when clearly it just ignores them.

You might also have a look at EditPadLite (free) and/or EditPadPro (not free, but not too expensive). Certainly better looking, better documented, and the 'lite' version has all I need.

While installing the application,

Notepad++ Setup - Choose components Dialog- Select the type of Install - Deselect the Auto-Updater check box.

Expanding on existing answers, here's my method for programmatically updating this:

# Note:
# - Notepad++ must be closed when you run this because when Notepad++ does its closing process, it re-writes the config.xml file with the config from memory
# - This script only updates one user profile, the current user's

$Path = "C:\Users\$($env:username)\AppData\Roaming\Notepad++\config.xml"

# Disable auto-checking for updates
(Get-Content $Path | Out-String) -Replace '(.*noUpdate.*)no</GUIConfig>', '$1yes</GUIConfig>' | Out-File $Path

# To re-enable auto-checking for updates
(Get-Content $Path | Out-String) -Replace '(.*noUpdate.*)yes</GUIConfig>', '$1no</GUIConfig>' | Out-File $Path

If you have updates pending (you can start an update without admin), but are unable to complete them (because you don't have admin), you will get an annoying message each time you open it, asking you to complete the update.

You can make this go away by deleting %appdata%\Notepad++\plugins\Config\PluginManagerGpUp.xml. This will also delete the plugin_install_temp folder which contains the updates, when you next run it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.