3

I got problem when I try to share the external hard drive over the network. Basically the hard drive are connected using USB port and having 3 partition. My machine work on Windows 7.

When I accessing on another PC, I got Strange error enter image description here

I've using Advanced Sharing and check permission to everyone and also grant permission full control.

Also tried to take ownership to my current user and restart the pc also.

Is there anything I forgot? Kindly your help Thanks

3

Two measures might help here. Long time since Windows 7, so I don't remember if one or both are enough.

Everyone permissions for anonymous users

  • In the Start menu, enter Edit group policy
  • Navigate to Computer Configuration\Windows Settings\Security Settings\Local Polices\Security Options
  • Find and double-click Network access: Let Everyone permissions apply to anonymous users
  • Set it to Enabled and click OK.

Enable the Guest account and give permissions on the share

  • In the Start menu, enter User Accounts
  • Click on Manage another account
  • Click Guest
  • You will be presented with the question Do you want to turn on the guest account?
  • Click Turn on
  • Now that it is enabled, give the Guest account all permissions on the share.
2

Please follow the steps below to share the external hard drive to the network and, for your particular error, please cross check the permission setting on Step 8:

Permission Setting

Taken from Adding an external hard drive to your network:

Step 1: Connect the external hard drive to the USB port of your server or computer that is always ON.

IMPORTANT: Take note of your server or computer’s IP Address as it will be used to map the shared hard drive on your network.

Step 2: Click the Start button, then click Computer. The external hard drive should be displayed.

Step 3: Right-click on the external drive, then select Share with. Click Advanced sharing….

Step 4: Click the Advanced Sharing… button.

Step 5: Check the Share this folder option. Click Add and then enter a name for the folder or drive you want to share.

NOTE: In this example, Shared_Storage is entered as the name of the external hard drive.

Step 6: Click the Permissions button.

Step 7: Select the Everyone option. This drive will be accessible to everyone connected to your network.

Step 8: Check the Allow boxes next to Full Control, Change or Read option.

Step 9: Click the Apply button and then click OK to close the User Settings window.

Step 10: Click OK to close the Permission window.

Step 11: Click Close to exit the Advanced Sharing window.

  • 1
    Link only answer is useless, especially when it will be broken. Can you elaborate on this a little more? – Toto Jun 3 '18 at 18:27
  • Thanks Toto for the guidance, amended accordingly. Thanks again. – Sayan Jun 4 '18 at 1:16
  • 2
    @Greenonline good edit, well done – bertieb Jun 4 '18 at 16:24
  • You must include the link from which you took your information from, otherwise the post will be deleted for plagiarism. I have amended your post for you accordingly. – Greenonline Jun 4 '18 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.