0

Running Debian 9, installed 7-zip 16.02 (64-bit) from debian repo.

I'm attempting to create a split 7zip archive, and I receive this error message:

7z a dir1.zip dir1 -v1k

7-Zip [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
p7zip Version 16.02 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs Intel(R) Celeron(R) CPU J3455 @ 1.50GHz (506C9),ASM,AES-NI)



System ERROR:
E_NOTIMPL

What's the deal? Older questions on this same issue are not helpful.

Is the volume split feature not implemented in this specific version of 7-zip?

Any help is greatly appreciated.

4
  • Do you use Debian default kernel or one of your own? What filesystem type are you on when launching the command? You can try prefixing it with strace that will give you more details on the OS commands that 7z is calling to pinpoint which operation generated the error E_NOTIMPL. Also 1k seems awfully small, why should a small value? Did you try changing it, using m for example and do you have then the same problem? It is certainly not a 7z problem I have the same version, and the same command as yours works okay (on Ubuntu) Jun 3 '18 at 22:50
  • Thanks for your response. I've tried multiple sizes and types (b, k, m, g). 1k was used just for testing. I even tried incorrect size types (like w) to make sure that it is recognizing the types correctly. Jun 4 '18 at 0:55
  • What the heck... I just tried it again... its working now! What is up with that?! What is happening between "then" and "now"? It's been 3 hours. The server was not rebooted after my initial reboots. It stayed online. :o I logged in via multiple putty sessions both then and now. This might need testing in a VM to see if "time after installation" is a factor for this issue. Because this correlates to the SO question I referenced in the original question... bizarre! Jun 4 '18 at 1:18
  • Did content of directory change? Permissions? Amount of free space to create archive? Etc. Jun 4 '18 at 1:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.