I use Server 2008 box as my primary machine (I'm a developer) so I've tried to configure it as much as is it can to a behave as a Vist Desktop.

I've attempted and failed to convinve Media Player 11 to play DVDs in the process I think I may have trashed its codec set or some such thing. It won't play Mp4 files (I'm not sure it ever did but I think its supposed to). I just get the dreaded "cannot play... might not support ... codec blah..." message.

Unfortunately you only have to wave the word "codec" at a search engine to be inundated with a wave of acronym diahrea which is impossible to decipher by video dummies like me.

Anyone know of a simple way to correct this without re-installing (or how how can simply re-install windows media player on 2008 that won't trash other stuff).

If anyone know how I can (if possible) convince Media player to play DVDs on server 2008 that would be a bonus. ;)


You can also try vlc (http://www.videolan.org/vlc/), which lets you play DVDs, but has the added advantages of

  1. Ignoring region coding!
  2. Skipping DVD bloat-ware (unskippable FBI warnings, promos, etc).

Not quite what you asked for, but in general a very useful alternative when that foreign disk (especially if you've lived in multiple "regions" like me) won't play.

  • Thanks thats quite neat, I can now play DVDs. It will play the MP4s but doesn't support the samr audio encoding so its silent. – AnthonyWJones Aug 2 '09 at 13:42

What you need is a 64-bit codec pack.

The 64-bit K-Lite Codec Pack should work nicely.

If you are running a 32-bit media player then try the 32-bit version.

  • I'm running the version of media player found in the Program Files (x86) folder. Isn't that a 32 bit app? Wouldn't I need 32 bit codecs for that? – AnthonyWJones Jul 28 '09 at 13:43
  • I'm not sure if that's a 32-bit or 64-bit binary. If it's in (x86) it' s probably 32-bit so try the 32-bit version of the same pack. – Mike McQuaid Jul 28 '09 at 14:03
  • The version of Media Player is 32 bit so I tried the 32 bit version. I didn't get anywhere with it. Unfortunately exactly as I predicted in my question happened. Once downloaded the installer presents me to the usual codec acronym diahrea, I accept the defaults. I can't be sure thats the correct thing to do but I've got no choice. Media Player still gives me the same error. – AnthonyWJones Aug 2 '09 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.