I have a network cable and a phone connected to my computer.

The phone uses an APN that have access to a single address. The network cable is connected to a network that have access to the internet.

When I open the site that only the phone can access I can't connect anymore to any other site until I disconnect the phone.

How to keep both connections?

I'm using Windows Vista, but solutions to other SO would be great too.


On windows, ForceBindIP allows you to link specific applications to specific network interfaces. E.g. you could set up internet explorer to connect through one and firefox to connect through the other. The network interfaces are identified by their IP address, which you can discover by running ipconfig on the command line. I haven't tested it.

An alternative solution which requires less command-line-fu is to run a virtual machine. VM software typically allows you to chose which network adapter is used by the VM. This doesn't have to cost anything; you could use the free vmware player with a free browser appliance (i.e. a preconfigured VM with ubuntu+firefox). The network bridging can be configured with c:\program files\vmware\vmware player\vmnetcfg.exe, which needs to be run with admin privileges.

edit: this answer shows how to configure a preferred network adapter on the physical machine.

  • One VM with network adapter A and another VM with network adapter B? – Daniel Moura Jul 15 '09 at 14:41
  • That would work, but I am guessing that there must be some way to configure your secondary network adapter for exclusive use by the VM, so that the host only uses the primary network adapter. – wcoenen Jul 15 '09 at 15:04

You can also use the ROUTE command in Windows to change the metrics of the adapters. A lower metric means that adapter/route is preferred. You could set up some scripts that would change the routes from one adapter to the other.


How are you connecting to the phone network? If it is a dial up connection, like the windows-based VPNs then there is a setting in the IP Protocol for the connection that essentially tells Windows to route all traffic through the dial up connection. Perhaps, you could simply un-check the box, called "Use default gateway on remote network." This is found in the Advanced settings of the IPv4 protocol under the Dial Up Connection.

In the end though, the box I mentioned above is just manipulating your routing table, so @Chris Thompson's answer still applies. Either manually adjust the routing table so all machines are accessible at the same time (assuming it is possible and there are not IP conflicts on the two networks) or possibly try the setting I mentioned.

Good luck..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.