2

I have performed HDD swap for new SSD on my Acer Aspire ES1-311 laptop. During disassembly I disconnected the battery by pushing button directly on my mobo and then unplugged the cables from the motherboard.

Then I proceeded to switch the drive, repaste the CPU cooler, clean the dust etc…

After plugging back to DC and installing fresh Windows and drivers directly from Acer's site everything works just fine, except for the battery.

It is detected by the Windows, I can get readings from HWMonitor (13V, cca 18% battery wear) and even build in battery status LED is on. But when I unplug the charger, laptop instantly switches off.

At that point I tried switching back to the old HDD but the same thing is happening and as a bonus I can't get to recovery partition because "laptop couldn't load it, try contacting your administrator". It probably got messed up during partition cloning or year ago when I made another partition for my dual boot.

I am probably accepting the fact that the battery has died, but it seems so weird because it was disconnected for the whole time and I didn't bend it/heat it/smashed screwdriver into it and the timing, that some of the cells died just now is very unlikely.

Before that battery had no problem with 5 hours of work.

I would be really grateful for any suggestion or advice, as I still hope, that this is software/firmware issue.

Methods I tried:

And probably some more, that I cannot find links to right now.

Thank you for any advice

Images of what I have done and what this looks like:

enter image description here enter image description here enter image description here enter image description here enter image description here

  • 3
    Sounds like you accidentally unplugged a cable. If the battery worked before the HDD was replace, then the battery should have worked, after the HDD was replaced. It isn’t clear which cables you disconnected. Hopefully you didn’t intentionally unplug cables associated with the charging circuit. – Ramhound Jun 6 '18 at 14:59
  • "During disassembly I disconnected the battery by pushing button directly on my mobo and then unplugged the cables from the motherboard." - what button? what cables? ... and why? – Attie Jun 6 '18 at 16:13
  • I have added link which leads to pictures. Sorry for inaccuracies. The button I was talking about is the one pushable by needle or something tiny through the plastic bottom cover. And by cables I meant the cluster of cables from battery to connector on the motherboard. – Martin Nemecek Jun 6 '18 at 19:33
  • Happy you solved this! But please do not edit a question with “Solved” details or declarations. If you have self-solved this issue, please be sure to post an answer to your question with details and then—when you can—check the answer off as the selected answer. – JakeGould Jun 6 '18 at 21:02
0

Given that the old install from the HDD is doing the same thing, and the battery was treated well during the swap, I have to assume that in the process of removing the bottom cover to replace the drive, something else must be going on other than drivers or software.

This battery seems to be wired in, have you tried reseating the connector to the motherboard (or wherever it goes)? You cleaned the laptop while it was apart, is it possible the connector got some dust bunnies lodged in it? Check the cables from the battery itself, did one get over-stressed or super bent when you reinstalled the back cover? These look like really high gauge cables (very thin), one that's pinched could cause issues.

Whatever the case, it's pretty clear that this is much more likely to do with the hardware rather than software/drivers. Go back and check your work, make sure the cable is seated all the way, in the proper orientation, after confirming the connector is free from debris.

  • I have added link to pictures. None of the pins seem to be bended or damaged. Same goes for the cables I don't see any damage or sharp angles nor any dust particles or oxidation blocking the pins. I have tried to plug it in multiple times but no reaction when it comes to power. Windows still can detect and measure it so some of the pins must be communicating. I don't really have any knowledge when it comes to fuses on board. Is it possible that some of them got fried? – Martin Nemecek Jun 6 '18 at 19:44
  • Downvoted because this is definitely not an answer, but extended commentary given fairly random/generic advice. In the end the original poster self solved this, but did so in an edit to the question. The answer should be that solution and the original poster should post that. – JakeGould Jun 6 '18 at 23:56
  • @JakeGould really? I appreciate constructive criticism, but this is hardly an "extended commentary." I give an assessment that directs OP to a more hardware related solution, why I think that's more likely, and some common fixes for such an issue. I posted before the solution was found, and as I expected, it was hardware related. – MagnaVis Jun 7 '18 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.