2

I'm experiencing an error with my FileZilla server, error 425. At first my problem seemed well experienced, except that I AM NOT IN PASSIVE MODE! It never switches to passive mode. Here is the log:

(000006)6/6/2018 16:20:40 PM - (not logged in) (192.168.1.16)> Connected on port 21, sending welcome message...
(000006)6/6/2018 16:20:40 PM - (not logged in) (192.168.1.16)> 220-FileZilla Server 0.9.60 beta
(000006)6/6/2018 16:20:40 PM - (not logged in) (192.168.1.16)> 220-Welcome to the local FTP server
(000006)6/6/2018 16:20:40 PM - (not logged in) (192.168.1.16)> 220 ELLIOTTS WIFI Initiated
(000006)6/6/2018 16:20:40 PM - (not logged in) (192.168.1.16)> OPTS UTF8 ON
(000006)6/6/2018 16:20:40 PM - (not logged in) (192.168.1.16)> 202 UTF8 mode is always enabled. No need to send this command.
(000006)6/6/2018 16:20:45 PM - (not logged in) (192.168.1.16)> USER Lucas
(000006)6/6/2018 16:20:45 PM - (not logged in) (192.168.1.16)> 331 Password required for lucas
(000006)6/6/2018 16:20:48 PM - (not logged in) (192.168.1.16)> PASS
(000006)6/6/2018 16:20:48 PM - lucas (192.168.1.16)> 230 Logged on
(000006)6/6/2018 16:20:50 PM - lucas (192.168.1.16)> PORT 192,168,1,16,194,21
(000006)6/6/2018 16:20:50 PM - lucas (192.168.1.16)> 200 Port command successful
(000006)6/6/2018 16:20:50 PM - lucas (192.168.1.16)> LIST
(000006)6/6/2018 16:20:50 PM - lucas (192.168.1.16)> 150 Opening data channel for directory listing of
(000006)6/6/2018 16:21:00 PM - lucas (192.168.1.16)> 425 Can't open data connection for transfer of

Note that those are local not public IPs. I'm not sure which ports could not be set up on my router, and I've even tried having no firewall on either machine. I'm thoroughly stumped and google seems to be offering no solutions.

I have tried many different computers on my local network, with or without firewall. It was working when I first set up my server, but then it suddenly stopped working. I have not installed any new programs or changed settings.

  • So that’s a local LAN connection right? Did you confirm the Windows firewall prompt for FileZilla when it appeared? – Daniel B Jun 6 '18 at 20:31
  • No such thing came up? I don't have firewall on the pc running ftp, and the other pc is windows 98. – Mark Deven Jun 6 '18 at 20:32
  • Which PC is running Windows 98? The FTP server PC or the FTP client PC? All modern Windows versions have a firewall built-in. You will also only be prompted once for any program. – Daniel B Jun 6 '18 at 20:37
  • The Windows 10 is running the server, and firewall is completely disabled. Windows 98 is connecting. Ive also tried from the same computer hosting. – Mark Deven Jun 6 '18 at 20:41
  • The server does not control if passive or active mode is used. It's the client. And you didn't tell us anything about the FTP client you are using. – Martin Prikryl Jun 7 '18 at 5:44
0

An FTP server does not control, if passive or active mode is used. It's a client that control this.

You need to tell your FTP client to use the passive mode. Though actually virtually all (decent) FTP client default to the passive mode.

From the sequence of commands used (particularly the OPTS UTF8 ON), it actually looks like you are using Windows command-line ftp.exe client. This client does not support the passive mode, on any version of Windows. See also How to use passive FTP mode in Windows command prompt?

| improve this answer | |
  • The problem is not that it is in passive mode, the problem is that I cannot transfer files or dir. I'm simply stating the fact that it is not in passive mode, since most 425 errors seem to be in passive mode. This was clear before my post was edited. – Mark Deven Jun 7 '18 at 13:05
  • I also do not have the ability to use anything other than the command line cmd.exe (and thus ftp.exe). This was working when I first rand the server, but about a day later it stopped working, without me changing anything. – Mark Deven Jun 7 '18 at 13:08
  • I do no think it was clear. Anyway, then the problem is most likely local, rather than server-side. So you have to tell us more about your local machine. – Martin Prikryl Jun 7 '18 at 13:17
  • I've tried in on 3 different computers. A windows 98 PC, a Windows 10 PC, and another Windows 10 PC. Ive tried with firewall and without. They are Dell, Lenovo, and Avid. – Mark Deven Jun 7 '18 at 14:08
  • Please add that to your question. And describe how do you connect to the server, and how the router is involved, when the IP's are local. – Martin Prikryl Jun 7 '18 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.