1

I have an issue that's been running for the past few days. This weekend, I could use my external (Seagate Backup Plus Slim) HDD just fine, I even put a couple dozens GigaBytes worth of movies on it without an issue. However, a couple hours later, it started being faulty while watching those same movies, randomly disconnecting, and giving VLC a hard time decoding all of this.

I now am almost positive that a couple of issues on my computer caused this, more precisely what seems to be a faulty USB hub driver (and?) memory issues. But that's not the point here.

My issue is that I need to be able to recover files from this hard drive (optional as well as completely mandatory), but I am facing a couple of issues.

The first of which is that I, for several hours, couldn't access it consistently. I just got stubborn and tried to get it to work (on the buggy computer) and I think it finished messing it up. And after a moment trying to understand where the issue was coming from, nothing. The hard drive just wasn't there for any computer.

I tried it on my girlfriend's, and it detected it... Under the RAW format. The size was right and everything, but no file was there, and I didn't want to format it over. So I headed to my Debian-operated computer, on which I fiddled for a couple hours more with TestDisk. There, using the Deeper Search, I discovered that Cylinder 3759/XX/YY (or something like that) was unreadable every time. I can find the files with PhotoRec, but my HDD being a 2TB one (and me not possessing anything as large as this), I can't just do a whole PhotoRec recovery.

Hence why I need to figure out how to get my partition table back despite the faulty sectors. I could just repair the sectors (well, check the drive and everything) but I don't know of my partition table would still be recoverable after then. And, in the case of the other way around, if I even can recover the partition table with faulty sector(s).

So, any help would be more than greatly appreciated! Just keep this in mind: my files are there. It's just not a normal process to get them back, since I have two issues going on at once. Thanks in advance!

  • Before attempting anything else you should make a clone with ddrescue. – Andrea Lazzarotto Jun 7 '18 at 11:32
  • @Andrea I'd like to but I don't have a large enough hard drive to clone my faulty one... – Rinyuaru-Kun Jun 7 '18 at 13:56
  • If the data is important, you shall buy another drive and work on the recovery. – Andrea Lazzarotto Jun 7 '18 at 15:09
  • As I commented below, I'll look for info about my warranty and if it's expired, that's what I'm gonna do. Thanks for the input :) – Rinyuaru-Kun Jun 7 '18 at 15:18
1

https://www.youtube.com/watch?v=O_kvJF87Drc

This procedure will allow you to write a new partition table with testdesk.

This link details the procedure without the video.

https://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

You may need to deal with the bad sectors in one way or another.

All hard drives have SMART built in, and it is suppose to hide bad sectors and replace them with spare. However, sometimes it doesn't work, and some times it needs a nudge. Some times it can't be helped.

  1. You can run software like SpinRite or mhdd on it, and see if it correct the sector, or at least trigger smart. In some cases repeatedly writing to the sector triggers SMART to do its job.

If that fails you have to recover the partition table first. The partition table and MBR actually reside in sector 0, and 0=63 are traditionally reserved anyway.

Then you can run chkdsk /R d: and it will scan and find the bad sectors. No, it can't fix them, but it can hide them so they are never used.

The NTFS file system also stores a backup file near the end of the partition. If that sector has gone bad then use gparted or similar to shrink the partition down say 100mb (or so) and that should move it out of harms way.

  • Thank you very much, I will dig into all this. I remember checking for SMART and having no response from it (despite the computer getting the right info from the device's manufacturer), is it possible that it doesn't have it afterall? – Rinyuaru-Kun Jun 7 '18 at 5:44
  • SMART is usually not implemented in external USB enclosures. Check Seagate's own tools to see if that particular one is supported. Bad Block reallocation is not handled by SMART, only reported by it to the user/OS. – Tetsujin Jun 7 '18 at 6:46
  • An external hard drive is usually just a regular hdd with a plastic chasis, and a tiny USB to SATA adapter, so many do support SMART. Whether or not its accessible over USB is a whole different matter. Some USB to SATA circuits allow SMART data to pass and some don't. – cybernard Jun 7 '18 at 11:40
  • It indeed is a regular HDD in a plastic case, but I don't know whether or not the SATA/USB adapter handles the SMART in that case. Also, I tried using Seagate tools, but they didn't do anything (no result... The tool itself looks reaaally outdated too, but heh) – Rinyuaru-Kun Jun 7 '18 at 13:58
  • @Rinyuaru-Kun If the drive isn't under warranty, or you don't care about the warranty. Then you can take it out, and connect it a PC with SATA cable to do the diagnostic work, it will be faster than USB 2 for sure. USB 3 would be the same speed. – cybernard Jun 7 '18 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.