1

I wanted to install JOSM on old Mint (https://josm.openstreetmap.de/wiki/Download#Ubuntu). So I added file josm.list to sources.list.d containing one line:

deb https://josm.openstreetmap.de/apt trusty universe

and tried:

# apt-get install josm

Translated output:

The following packages have unfulfilled dependencies:
 josm: Requires: openjdk-8-jre but can not be installed or
                 java8-runtime but can not be installed

but:

$ java -version
java version "1.8.0_141"
Java(TM) SE Runtime Environment (build 1.8.0_141-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.141-b15, mixed mode)

I know it isn't latest 1.8.0_17x, but it is 1.8... What should I do to install josm?

0

OK, I posted question and minutes after I found a solution... So frequent...

# apt-add-repository ppa:openjdk-r/ppa
# apt-get-update
# apt-get install josm

And JOSM is fully working, downloading data from OSM server.

Thanks for beeing rubber ducks! (truly, thank you)

-1

On JOSM download webpage is descripbed how to add JOSM into your favourite distro. Probably latest stable. In latest Mint 20.1 was josm outdated. Link 1 helped me.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.