I seem to be having a weird problem and hope someone can help me out. I got a high resolution monitor to upgrade from my existing one. Here is the output from xrandr

Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 8192 x 8192
VGA-0 connected 1280x1024+0+56 (normal left inverted right x axis y axis) 338mm x 270mm
1280x1024      60.0*+   75.0  
1152x864       75.0  
1024x768       75.1     70.1     60.0  
832x624        74.6  
800x600        72.2     75.0     60.3  
640x480        75.0     72.8     60.0  
720x400        70.1  
DVI-0 connected primary 1920x1080+1280+0 (normal left inverted right x axis y axis) 600mm x 340mm
3840x2160      30.0 +   25.0     24.0     30.0     24.0  
2560x1440      60.0  
1920x1080      60.0*    59.9     30.0     30.0  
1600x900       60.0  
1280x1024      60.0  
1280x800       59.9  
1152x864       60.0  
1280x720       60.0     59.9  
1024x768       60.0  
800x600        60.3  
720x480        60.0     59.9  
640x480        60.0     59.9  

One of them (the old one) is connected via VGA, whereas the new one is connected via a dvi to hdmi dongle. I've an integrated GPU The output from lspci | grep VGA is

01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880 [Radeon HD 4200]

My question is two fold.

  1. The Radeon HD 4200 supports resolution only upto 1920x1200 per this thread for dvi. Does this mean that if I get a vga to hdmi dongle, I can get to 2560x1600 resolution? Or do I need to find a new graphics card and insert into an open pci slot?
  2. I'm also stuck with a bizarre problem. When I suspend/reboot/wake up etc, I need to have my old monitor connected to the VGA port all the time, else the new monitor does not switch on and just stays blank. This has to be configuration/software related. I also followed instructions listed here to pull in some packages, rebooted. But no luck.

I only want to use my new monitor (no dual monitor setup needed). Any pointers much appreciated. Thanks in advance.

  • The linked answer says "2560x1600 (dual-link DVI)". Does the new monitor work if the old one is disconnected before boot (shutdown-disconnect-boot, no reboot)? – danzel Jun 9 at 9:00
  • No. The new monitor will not work if the old monitor is disconnected (but only during suspend/wake-up and reboot. It works fine if I connect the old monitor and the new monitor, reboot (or wake up), then disconnect the old monitor. Basically anytime I try and wake up/reboot with just the new monitor, the monitor appears to not work. – broccoli Jun 9 at 14:18
  • I meant boot with only the new monitor attached, not suspend/wakeup/reboot. Did you try to disable the old monitor when it is attached? – danzel Jun 9 at 14:20
  • Yes. I've tried booting with just the new monitor attached to the dvi port. No luck. It does not pick it up. Oddly, I do see the "...Ubuntu..." screen and then it blanks out. – broccoli Jun 10 at 0:20
  • That is indeed interesting, because it indicates a faulty configuration (not from your side). As I said, did you try to disable the VGA screen in system settings? – danzel Jun 11 at 23:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.