0

I am stuck on Windows XP installation on an AHCI-only SATA-controller system, and ask therefore for help. VM is also not an option because of performance issues.

I have a newer laptop with Windows 10 installed on it. For a specific reason I need to install a Windows XP (and make that system dual-boot). The WinXP is needed so please do not argue or discuss about whether it is good, bad etc.

This laptop (Asus X540L) does only support AHCI SATA-mode. In the BIOS no IDE can be selected, only AHCI.

Since the Windows XP can not handle AHCI SATA hard disks by default, I tried to put a WinXP into a VM. But this is, because of its' poor performance, a very bad solution which does not achive my goal. So VM did not solved the case, therefore other solution is required.

Because the solution with VM was not performant enough, I slipstreamed the latest WinXP-working drivers (I don't have floppy drive in this laptop) to install it. The SATA-controller is called:

Intel(R) 9 Series Chipset Family SATA AHCI Controller

Driver parameters are:

PCI\VEN_8086&DEV_9C83&CC_0106

Therefore I downloaded the official Intel RST driver version 13.6.0.1002 ("floppy" version, made for slipstreaming, can be downloaded from here).

I integrated these drivers by using the "Multiple driver folder" function on the driver integration screen of nLite. I also integrated the SP3. Finally I got the disk, burned it and tried to install the WinXP.

I got at frist "Stop error code 0x000000A5" error when you tried installing Windows XP with following message:

The bios in this system is not fully ACPI compliant. Please contact your system vendor for an updated bios. If you are unable to obtain an updated bios or the latest bios supplied by your vendor is not ACPI compliant, you can turn off ACPI mode during text mode setup. To do this, simply press the F7 key when you are prompted to install storage drivers. The system will not notify you that the F7 key was pressed--it will silently disable ACPI and allow you to continue your installation.

After the restart I pressed checked my BIOS but did not find any ACPI-relevant setting. Therefore I restarted the WinXP installer and pressed F7 (as the BSOD said), but after loading the drivers I get BSOD with error code 0x0000007B:

STOP : 0x0000007B (0xF78D2524,0xC0000034,0x00000000,0x00000000)

Now I have no more ideas. I made sure that my install disk has SP3 slipstreamed into it, and while I was at it, I as well added the latest AHCI drivers as well (like written above).

But I still get BSOD. Please help meg, what else could I do.

  • 1
    Does the reason for dual booting necessitate installing on the bare metal? Often a VM can suffice except when dedicated hardware support is required... – Mokubai Jun 9 '18 at 9:13
  • XP is an older installation. It doesn't work well with newer hardware. You probably need to slipstream the correct drivers for your motherboard into the installation before it will work succesfully. Note: the wrong drivers will cause problems, so don't slipstream drivers into the mix unless you are absolutely sure these are the correct drivers, and it are all of them. – LPChip Jun 9 '18 at 9:24
  • @LPChip: exactly what I am done is that I checked the AHCI controller's device ID and then checked the driver. Result: device ID is correct in the Intel driver, and this can work under WinXP (checked the .inf file). – A.V. Jun 9 '18 at 10:25
  • @Mokubai: I absolutely agree with you. But I tried it: VM is bad in my scenario because of performance issues. I also extend my question. – A.V. Jun 9 '18 at 10:26
  • But is it only that driver that you need? Or is it actually BSoDing on another driver? – LPChip Jun 9 '18 at 10:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.