3

I'm trying to setup a dd-wrt router (Linksys WRT400N, Firmware: DD-WRT v3.0-r36079 std (06/01/18)) as a repeater bridge. I'm following this instruction the Qualcomm Atheros section.

I have my computer wired to the dd-wrt router I'm trying to config. First I set it to the client bridge mode (so no virtual interface for wireless yet). At this step, the bridge router is connected to the main router, I can access both routers, and I can access the Internet. My main router address is 192.168.1.1, the DHCP IP range is 192.168.1.10~99, the bridge router address is 192.168.1.2. However, the first strange thing I found is that my computer IP now is 192.168.1.129, which is outside of the DHCP range. Then, either wait for a while, or reboot the router, my computer will lose its IP address. I can't access either routers, nor the internet. And there's nothing I can do to re-connect to the bridge router except factory resetting it. So I can't even proceed to the repeater bridge step.

What exactly does the bridge router do in the client bridge mode? How do the devices connected to the bridge router get IP addresses? They should get IPs from the DHCP server on the main router, right? Then why would my computer first gets an address that's out of the range? And the bridge router itself should get no IP address? Did I miss anything?


Update:

Now I think about it, my computer might got the IP 192.168.1.129 before the 2nd router set to the client bridge mode. After the client bridge mode, my computer never got IP from the main router.


Update 2:

It turned out I simply needed to reboot the main router. After that the client bridge mode is working fine, and I added a virtual interface with different SSID and the repeater bridge is also working. Now from my main router and I can see both the bridge router and the device connected to the bridge router (and they all have the same IP address). I can access both routers no matter which one I connect to.

BTW, the repeater WiFi signal from the virtual interface is at the same channel as the main router, will this cause interference? Is there a way to put it on another channel?

0
3

As I am sure you have found, DD-WRT documentation is lacking vital information in some areas. beware that on some models repeater bridge makes the router unstable, requiring frequent reboots. sometimes its just the hardware and sometimes it can be resolved with a different build# of DD-WRT found in the dev section. (try to always run stable, and none-beta versions) this limitation is non-existent on routers with two physical radios.

Set the primary router DHCP range to "192.168.1.2 through 192.168.2.249"

This is how to configure it on a router with one radio.

Plug directly into the second router while configuring it. (this is assuming you have factory reset it) In the second routers configuration page go to the setup tab.

dd-wrt setup tab

dd-setup Put the second router at the end of the first routers sub-net. -"192.168.1.254 /24"
Put it in DHCP forwarding mode and point it to the main router IP. -"192.168.1.1"
WAN & STP disabled.
Now would be a good time to enter a NTP server. example: "pool.ntp.org".
(this will give the router an accurate system time)
Hit Save.

In the Wireless tab --> Basic settings

wireless setup tab

wi-setup Set the Wireless mode to Client Bridge.
Set the wireless network mode to what wireless mode you want it to connect to the first.
(choose the fastest mode both support).
Set your first routers SSID into the wireless network name box, or you can automatically populate it under Status -> Wireless. Hit Save, then go to the Wireless Security sub-tab and make sure your pre-shared key is correct. do not create the virtual interface just yet.
Hit Save.

In the Security Tab

firewall

Disable the SPI firewall.
Hit Save.

Reboot the router under the administration tab. Plugged in wired to the router, it will come back up with the .254 address, you should be able to go to Status -> Wireless and see that you are connected to the first routers wireless network. (with noise readings, RSSI etc) You should be given a DHCP IP address from inside the first routers Subnet.

go back to the wireless tab and create the virtual WLAN interface.

wireless setup tab

reapeater

Hit Save.
don't forget to set the WPA-PSK for the virtual interface under the wireless security tab.

this brings up a choice, you can make this a separate SSID from the first with a different password, or you can match the settings from the first exactly, and the clients will automatically roam.

At this point i would recommend that you either setup the connection watchdog, or a timed reboot under the administration tab. (i find that the timed reboot works well for 24 hour periods)

Administration tab -> keep-alive

admin

once set, hit save, then apply. and finally reboot the router. backup these settings to a config file under the "admin --> backup tab". if this doesn't work for you, try another build release. use the backup you created to save yourself time if you do need to try another version

Hope this helps you out. Let me know if you run into trouble.

5
  • Thank you for the detailed reply. But it turned out I simply needed to reboot my main router, for whatever reason... after that the repeater bridge is working. – LWZ Jun 9 '18 at 22:08
  • I would still enable the scheduled reboot. Disable the things mentioned, you will get better throughput on the second router if you do, as it will free up some ram. If you have found this post at all useful, or think it could be useful to someone else searching. Consider marking it as answered. Regards. – Tim_Stewart Jun 9 '18 at 22:18
  • @LWZ there is no way to change the channel the virtual interface is working on. Both the real SSID and virtual are using the same physical radio. They will not "interfere" but it does half the available bandwidth. BTW, if you use the same SSID as the first with same WPA2-PSK it will enable wireless client roaming. – Tim_Stewart Jun 9 '18 at 22:24
  • Well if I set one radio (2.4GHz) to client bridge mode, and instead of adding a virtual interface on the same radio, if I set the 2nd radio (5GHz) to AP mode, will it still act as a repeater? And I will not suffer from half the bandwidth? – LWZ Jun 11 '18 at 16:06
  • Yes, it will act as a repeater. And No, it wouldn't suffer from the limitation. But only devices on the 5.8ghz band could connect to the second radio. – Tim_Stewart Jun 11 '18 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.