3

I got a new pc, the internet speed is somehow capped at 5 MB/s on every program .. Torrent, steam, chrome downloads and everything.

I tried with my laptop and other pc and it's runs all good, no internet cap there.

Tried to reinstall drivers, and updating them to the least update... didn't solve the problem.

Anyone can help me?

  • 2
    What's the Windows 10 version? Ethernet or WiFi? Any driver issue? What's the real speed of that connection? Did you change any registry or modify any settings recently? – Biswapriyo Jun 10 '18 at 15:48
  • @Biswapriyo , my internet speed in normal situations in steam on other devices are +10MB/s , my internet connection is 100Mb/s , i connect via ethernet. Windows version: Windows 10 Home 64bit build 15063 – GLOB GVI Jun 10 '18 at 15:52
  • @Biswapriyo , I didn't modify the registry, and didn't do that much changes on setting. – GLOB GVI Jun 10 '18 at 16:11
  • Are you getting 5 MB/s total, or 5 MB/s per program? In other words, if you start 2-3 downloads in different programs at once, does the sum reach 10 MB/s (100 Mbps)? – grawity Jun 10 '18 at 16:47
  • @grawity, 5 MB/s total, if one program downloading something .. than every other program that uses internet get unuseable, unless the downloading speed drop less then 5MB/s in the program that downloading. So it's possibly that's is total of 5 MB/s on the whole pc. – GLOB GVI Jun 10 '18 at 17:12
2

windows 10 can improperly set the auto tuning levels.

Use Cortana to search for “CMD.”

run cmd

Right-click on “Command Prompt” and click “Run as administrator.”

run command

netsh interface tcp show global

Look for “Receive Window Auto-Tuning Level” under the results in the Command Prompt window.

auto-tune If it’s set to enabled, it’s turned on, and may be causing your internet issues.

To disable it, run the following command:

netsh int tcp set global autotuninglevel=disabled

the results should be immediate, although it is recommended to restart your PC and power cycle your network gear just to be safe.

Successful command entered:

success

If that doesn't work for you, you can try to: Press Windows key on your keyboard, then type CMD on search, right-click on the result and choose Run as Admin. Type these following commands to reset your internet/network settings:

netsh int ip reset resetlog.txt
ipconfig /flushdns
netsh winsock reset
Restart your PC and see if the issue is resolved.

Note, both of these solutions are shots in the dark. You have left us with very little information to try and help you with this issue.

references:

https://www.onmsft.com/news/windows-10-limiting-internet-speed-heres-change

https://www.technorms.com/60413/how-to-stop-windows-10-from-limiting-your-internet

https://www.ghacks.net/2016/08/05/windows-10-limiting-internet-speed/

  • Have seen this solution many times, didn't work. I tried also to change speed&duplex to different variables, nothing worked. It's giving me real headache. – GLOB GVI Jun 13 '18 at 11:32
  • Add more info to the question, I'll try to help. Make model of the router. Make model of the laptop, what network adapter is in it? Are you using wired or wireless? This answer was a shot in the dark. – Tim_Stewart Jun 13 '18 at 16:59
  • Internet Connection : Ethernet output in wall(fiber) -> router -> ethernet cable -> My pc. @Tim_Stewart – GLOB GVI Jun 16 '18 at 18:16
  • ,Ethernet adapter(+ driver[+ version]) : Realtek PCIe GBE Family Controller 10.10.714.2016 – GLOB GVI Jun 16 '18 at 18:19
1

I had a similar problem during an scp copy over my LAN under Windows 10. I have gigabit adapters on both ends. Factoring in scp overhead, I should have been getting a transfer rate between 50-70 MB/sec--wasn't getting that though.

From the network graph in the task manager, my connection was topping out at 100Mbit (~12 MB/sec). It would occasionally burst to 500Mbit for a few seconds, then fall back to 100M--or less. Tried swapping out cables, nics, etc... no dice.

Then I tried disabling the QoS Packet Scheduler under my network interface. That fixed it for me!

Surprised that was it though. From what I recall, Microsoft's QoS Packet Scheduler has been causing similar headaches since Windows XP. I'd have figured it would be in better shape by now...

  • Thanks, worked for me, just had to remove the QOS Packet Scheduler and then disable and re enable the wireles card, went from 30Mbps to 127Mbps – Untherxadyus May 30 at 0:00
0

In case this helps somebody else: I have a 10Gbe network and could never reach more then 700Mb/s on my windows machine. Long story (and MS paid support later), I finally started un-installing stuff.

Norton Utilities was killing my bandwidth by a factor of 8. After the uninstall, I easily achieved 4Gb/s full duplex. (My Linux server on same hardware achieves 9Gb/s, but that's another story.)

Anyways, hope this helps someone else who struggles with this maddening state!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.