I want to connect to my Active Directory domain through a VPN connection. I am using Windows 10 and connecting using the Windows VPN connection. I understand that in order to do this I must connect to the VPN before authenticating and have followed these steps:


Where I get hung up is that the VPN connection isn't available at the login screen as shown here (I understand this is via Windows 7 but the idea is the same and the connection should appear): enter image description here

The author of the article states,

"It is also very important to check the box “Allow other people to use this connection” as you will soon have a domain account which will require access to this VPN connection."

However, when I try to check this box I get this:

"Cannot enable shared access. Error 87: the parameter is incorrect":

enter image description here

I read somewhere that I needed to enable split tunneling for this to work so I followed these instructions:


This did not resolve the issue. I still do not have a link to connect to the VPN prior to login and I still get the error 87. How do I resolve this?

2 Answers 2


The correct way to add a VPN connection to access an Active Directory domain prior to Windows login in Windows 10:

In the Windows search bar, type "Control Panel" and open the control panel.

  1. Select "Network and Internet."
  2. Select "Network and Sharing Center."
  3. Click on the link that says "Set up a new connection or network."
  4. Select "Connect to a workplace."
  5. Select "No, create a new connection."
  6. Select "Use my Internet connection (VPN).
  7. Enter the Internet IP address for your VPN and give the connection a name.
  8. Click the box that says "Allow other people to use this connection.
  9. Click "Create."
  10. Go back to the Network and Sharing Center and click the link that says "Change adapter settings."
  11. Right-click on your connection and select "Properties."
  12. Finish any other configuration that may be specific to your scenario.
  • In 2020 using Windows 10 1909, this still the only way to do it.
    – CarlosH.
    Jan 28, 2020 at 9:52

Please go back and re-read your instructions. It does not say anything about turning on internet connection sharing.

It says to choose the option to allow other people to use this connection, which is done at the time you create the VPN connection.

What you show you are trying to do is enable internet connection sharing which is completely unrelated and should not be turned on for the VPN connection.

If you missed the option to allow other people to use this connection, then you can copy the VPN connection file from your user profile to the shared user profile to make it available to all users:

  • User-version: C:\Users\<UserName>\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

  • Shared-version: C:\ProgramData\Microsoft\Network\Connections\Pbk\rasphone.pbk

  • I guess the reason I misunderstood is that in Windows 10, which I am using, there is no option for “Allow other people to use this connection" when you use the Windows 10 route and go to Windows Settings>VPN>Add a VPN Connection. It simply doesn't exist. I have discovered that the correct way to do this is to set up the connection through Network and Sharing Center>Set up a new connection or network, then select "Connect to a workplace. Then you have the option. Jun 23, 2018 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.