1

Sometimes, when I want to shutdown Windows 10, it aborts after a few secondes, because background tasks were not closed in this time.

Is it possible to however shutdown the operating system? In Windows 7 it was, it just waits until all background tasks are closed. But in 10, it aborts it.

This is especially bad, when you e. g. tell WinSCP shutdown after download and the OS aborts it.

1

shutdown has this functionallity to shut down/restart even though you have other tasks opened. Simply press Win+R and type in shutdown /s /f /t 0 and your computer shuts down.

/s means "shutdown". You can replace it with /r to instead restart.
/f means forcefully. This is the thing that makes your computer shut down even though it has still programs open in the background.
/t 0 means "in 0 seconds".

8
  • oh, well, thanks. But you misunderstood me. I mean the graphical shutdown via the start menu. This cancels the shutdown after a few seconds automatically, if the background tasks weren't closed in this short time window. And I want it to wait until all background tasks were been closed. So, the shutdown process should never ever be interrupted (like in Windows 7: It waits, if neccessary, for hours with the shutdown, but it never stops the process of shutting down. All I want is this old behaviour ported to Windows 10) – alpham8 Jun 15 '18 at 11:56
  • You could lower the value for the waiting duration for running apps to be killed. – user448673 Jun 16 '18 at 13:45
  • I'll never learn that pressing enter posts the comment in Stackexchange. However what I wanted to add is: Change the registry key HKEY_CURRENT_USER\Control Panel\Desktop\WaitToKillAppTimeout. Just lower the value by half or more. – user448673 Jun 16 '18 at 14:10
  • Ok, that would be one workaround. But is it also possible to let windows wait for hours before it aborts the shutdown? – alpham8 Jun 17 '18 at 15:14
  • You could do the opposite and just enter a high number as the value of that registration key. – user448673 Jun 18 '18 at 19:56
1

Anyway, I found my own answer. But thanks @Adem for giving me the right hint:

In these two links all you need is explained:

I really like the first one, since this site explains it more detailed.

In short, I have now the following registry values:

  • AutoEndTasks 1
  • HungAppTimeout to 8 minutes
  • WaitToKillAppTimeout to 10 minutes
  • WaitToKillServiceTimeout to 8 minutes

So, that there is a 2 minutes delay between killing and shutdown. Should be enough time for all apps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.