1

On my System running Windows 10 Professional, I am using Visual Studio 2015, which is the standard program associated to Text-Files, i.e all files with a suffix .txt, which means all files of this type are automatically opened with Visual Studio.

To use another program as default, I right-click a .txt-file, select "open with" and chose another program and tick the checkbox "always open with...". From that time on, my .txt files are opened by that other program (in this case PSPad), which is the behaviour I expect.

However, after I reboot my system, .txt files will reopen in Visual Studio 2015 again, which is not what I expect. So either Visual Studio 2015 itself, or some other process keeps re-assigning the defaul app settings. How can I permanently set PSPad as the default editor for .txt-files?

0

Visual Studio will attempt to repair any broken file associations (those not associated with a valid application) at startup. I suggest the following two manipulations.

  • Check if txt is included in VS Tools -> Options -> Text Editor -> File Extension, and Remove in that case.

  • Go to Default Programs -> Associate a file type or protocol with a program -> Choose default apps by file type, scroll down to .txt and click, then choose your text editor if it is not already set correctly.

If these two measures are not enough, then your Visual Studio setup has a problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.