The editor shows the text on my external monitor as scrambled almost as if the text is written over each other, the line the cursor is on shows normal though, and in a smaller font. Everything displays fine on my laptop's own screen. I am using Windows 10. Anyone have any idea how to fix this?

1 Answer 1


Right click on desktop, go to Display then you see the a slider with a heading saying, Change the size of text.... Move the slider to where it's appropriate and you are good to go.

Changing display props. of a specific app: You can right click the text editor or whatever software is not responding, go to properties then compatibility. Below you will find some DPI settings.You should change the High DPI scaling override to be performed by the system. Everything will be running fine now.

For TEXwork users go to Edit>>Preferences>>Preview tab Over there you will find Screen resolution value in dpi. Now bring a real ruler and match the one shown on the screen and adjust dpi value so that one inch in the screen is one inch in reality. Then you are good to go. Here you can enter the dpi of your monitor

Okay my cousin had TexStudio on his machine and I would suggest you to go to Options>>Cofigure>>Internal PDF Viewer and set the dpi value according to that on the box of your new monitor.This is very similar to what I did in TeXworks.

  • I suggest you to keep the text open while you adjust the slider Jun 12, 2018 at 14:33
  • That works, although I was hoping for something that won't change the settings for all my other applications as well, not really a fan of oversized text on my external monitor. Jun 13, 2018 at 6:22
  • I can of course help you with that too. Jun 13, 2018 at 6:48
  • I have edited the answer, mark it as an answer if it helps. Jun 13, 2018 at 6:51
  • Oky that works took some trial and error, perhaps just adjust your answer to say specifically to say you should change the High DPI scaling override to be performed by the system. I will mark ist as answered. Jun 13, 2018 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.