We recently had a power interruption, and our wifi thermostat now has intermittent connectivity. I contacted the thermostat manufacturer, and they said that nslookup has to work for the thermostat to work. They gave me some host names to use to test nslookup.

I have a router with both a 5GHz and 2.4GHz network. The nslookups work on the 5GHz network, but not on the 2.4GHz network. The thermostat supports only 2.4GHz connection.

I've tried resetting everything - router, thermostat, modem. Sometimes, resetting these will make the thermostat work for a few hours, but it eventually disconnects again.

None of the computers we have connected to the network indicate any problem with internet connectivity, other than the failed nslookups.

Does anyone know why the nslookups would work on the 5GHz network but not the 2.4GHz network?

I would just contact the ISP, but we have Spectrum, and when I've contacted them in the past, their support has been worse than awful. I was put on hold literally for several hours, and when I was fortunate enough to have someone answer, the person usually knew less about how to fix the problem than I did, which isn't much. I would switch to the other ISP in our area (AT&T), but I've heard they are even worse.

  • 1
    If nslookup isn't working, that indicates a lack of IP connectivity. That's not likely a failure specific to nslookup given that you report other devices have Internet connectivity; instead, there's probably an issue with wireless connectivity for the thermostat. Given the problem began after the power interruption, my guess is either the router or thermostat suffered electrical damage. A helpful test would be to set up another 2.4 GHz router and see if the thermostat can maintain a connection to it. If yes, your router is at fault. If no, the thermostat is likely to blame. – I say Reinstate Monica Jun 12 '18 at 17:30
  • I have another router, so I will try that. Thanks. – plafratt Jun 12 '18 at 17:37
  • Although, one thing that just occurred to me is that the router is connected to a surge protector. – plafratt Jun 12 '18 at 17:44
  • 1
    it's possible the router is fine. But you need to know for sure and this test will help establish that fact. – I say Reinstate Monica Jun 12 '18 at 17:46

I think that I may have figured out how to fix this. I noticed that nslookup worked on the 2.4GHz network when I specified an IPv4 DNS (e.g. "nslookup msn.com"), but not when I specified an IPv6 DNS. So this made me curious if the problem was specific to IPv6. So I went into the router settings for IPv6. The configuration was set to auto-detect, but there was also an IPv6 configuration "wizard." I ran the wizard, and when the router booted back up, the IPv6 configuration had been switched from auto-detect to "SLAAC/DHCPv6". Since that change, it seems like it has been working. However, some of the things I've done in the past have made it work for only a couple of days, so I will see what happens.

  • Although I still don't know why this problem just came up now. I would have guessed that the power interruption caused my router settings to get reset, but none of the other router settings were affected by the interruption, so I assume that the IPv6 settings weren't either. – plafratt Jun 13 '18 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.