2

I have multiple Windows 7 computers on a Windows workgroup network (not a domain and not a Home Group). UAC is enabled on all computers. I have an identical account named "Standard User" created as a standard user on two of the computers, with both accounts using the same password. I have logged into one of the computers using its "Standard User" account. I want to create a file in a shared folder on the OTHER computer that also has the identical "Standard User" account and password. I have configured both the Sharing and Security for the shared folder that I want to create the file in with full rights for the "Standard User" account.

When I try to create a Notepad file in the destination shared folder I get a message that says access to the destination folder has been denied. I've spent a couple of hours trying to understand the reason for this message. When I attempt the same operation as a Administrator User it works perfectly.

Am I correct in my understanding that a standard user is only granted read and execute rights when doing a network login to another computer, even when the standard user has specifically been granted full rights to the destination folder?

Thanks In Advance For Your Help!

UPDATE 6/14/2018: After some more testing I discovered that I had shared the root C:\ several years ago when I was first getting started with workgroup networking. So, the folder I am trying to reach with a standard user account across my Windows workgroup network is actually a subfolder of the shared root C:\. I decided to share the subfolder with the standard user with Read and Change share permissions (using the Share tab) and change the NTFS permissions (using the "Security" tab) to Full Control to see if write access would be granted to the subfolder. Still no joy - the remote standard user still couldn't write to the subfolder - even though I had shared the subfolder with Read and Change share permissions and set the NTFS permissions to Full Control.

After I discovered that the root C:\ had previously been shared, it occurred to me that maybe the root C:\ share was controlling the subfolder share. So, I added the standard user to the root C:\ share with Read and Change permissions. Bingo - it worked!! Just to make sure that it was a root C:\ share permission that was causing my problem, I removed the root C:\ share Change permission and tried to write to the subfolder. It failed. Re-enabling the root C:\ share Change permission restored the ability to write to the subfolder.

It appears that the root C:\ share permissions are controlling the subfolder share permissions. Since there isn't any obvious share permissions inheritance control in the Windows GUI (like there is for NTFS permissions) I'm assuming that there is some sort of "hidden inheritance" that is causing the root C:\ share permissions to control the share permissions for its subfolders. Is this correct? If so would you please explain how this works or point me to documentation that explains it?

  • Are your computers using Microsoft or local logins? – harrymc Jun 12 '18 at 17:36
  • Local account logins. – Bill Vallance Jun 12 '18 at 17:39
  • Try to set the Share permissions for Everyone (not the folder permissions). – harrymc Jun 12 '18 at 17:45
  • I have already configured EVERYONE with full share permissions. Just for ducks, I added EVERYONE to the Security permission and gave it Modify permission. Still doesn't work. – Bill Vallance Jun 12 '18 at 17:53
  • Have you created the shares from Standard User or from Administrator? Sometimes it's a problem when the shares are created by an account with higher permissions than the user. (Use @harrymc at the start of your answer for me to be notified.) – harrymc Jun 13 '18 at 19:51
0

Well, this is embarrassing. It turns out that I was trying to create a file in the C:\Folder1\Subfolder1 via the root C:\ share listed in the Network section of Windows Explorer. What I missed, further down in the list of shares, was the actual share for Subfolder1. Because I was navigating to Subfolder1 via the root C:\ share, the Sharing permissions for Subfolder1 in that path were being controlled by the root C:\ Sharing permissions (which had the Everyone group set to Read only). Once I saw the "direct" share for Subfolder1 (labeled "Subfolder1") further down in the list of shares I could create the file without a problem using a standard user account.

I'd like to thank @harrymc for putting me on the right path to understanding my problem. I'd also like to give him credit for the answer to my question, but I don't know if this is possible since I answered my own question.

As a fix for this issue I am now prefacing all of my network share names with the characters "NS-" (abbreviation for "Network Share") so that all network shares will be grouped and sorted TOGETHER in the Network section of Windows Explorer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.