4

Fedora Linux 28: Something is stealing certain key combinations. When I visit http://en.key-test.ru/ I can activate CTRL-SHIFT-ALT-q (and CTRL-SHIFT-ALT + most other keys) but not CTRL-SHIFT-ALT-d

I have tried in both Firefox and in Chrome. The problem exists in both Gnome, Gnome Classic and KDE.

I went through my keyboard shortcuts, and there are no shortcuts defined for CTRL-SHIFT-ALT d. I can temporarily make CTRL-SHIFT-ALT-d activate an application; so keystrokes are getting through to some parts of the desktop.

When I run xev, I see the following when pressing CTRL-SHIFT-ALT-d:

KeyPress event, serial 34, synthetic NO, window 0x3200001,
    root 0x2ac, subw 0x3200002, time 2322960, (53,48), root:(1015,177),
    state 0x10, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x3200001,
    root 0x2ac, subw 0x3200002, time 2326560, (53,48), root:(1015,177),
    state 0x14, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x3200001,
    root 0x2ac, subw 0x3200002, time 2328408, (53,48), root:(1015,177),
    state 0x15, keycode 64 (keysym 0xffe7, Meta_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

FocusOut event, serial 37, synthetic NO, window 0x3200001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 37, synthetic NO, window 0x3200001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  4294967212 0   0   0   32  0   4   0   1   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

If I run CTRL-SHIFT-ALT-q, i don't see the FocusOut/FocusIn/KeymapNotify events.

How do I find out what is stealing/modifying my key presses?

A co-worker of mine has seen the same phenomenon when using Ubuntu. I cannot reproduce the problem in CentOS 7.5.

2
  • 3
    I don't know any better way than killing X clients one after the other, possibly using xlsclients etc. to guide you, and testing to see when they are no longer stolen. Usually the prime suspects are the Window Manager and input frameworks, but if it happens both in Gnome and KDE, it might be something else. And yes, FocusIn/Out events mean some other X client is stealing the events.
    – dirkt
    Jun 15 '18 at 11:08
  • 1
    dirkt: Thanks, that allowed me to identify the culprit. It was Skype: CTRL-ALT-SHIFT-d activates an extra "Debug" menu item in Skype, and there does not seem to be a way to disable it in Skype. Jun 15 '18 at 12:38
4

See dirkt's hint which turned out to be very useful:

I don't know any better way than killing X clients one after the other, possibly using xlsclients etc. to guide you, and testing to see when they are no longer stolen.

Using xlsclients -la, I found a list of X apps, including those running in the background. I started killing them; some of the process terminations made my Gnome session break down, but I eventually found that shutting down the skypeforlinux process made CTRL+ALT+SHIFT+D work for me.

It turns out that in Skype an extra "Debug" menu item appears if you press CTRL+ALT+SHIFT+D. It seems this behaviour cannot be disabled in Skype.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.