I have a VM on VirtualBox running windows 2012 r2 and I tried to download updates, system connected to update server and told me all updates I need, but when I try to download them its stuck at 0%

Things I have tried:

  • ensuring no proxy is needed
  • restarting windows update service
  • deleting Windows\SoftwareDistribution and restarting windows Update service
  • one off installing updates in order of the patches (this got me through the first 5 updates but then I'm stuck again at KB2919355 and even that one wont download solo)

Any further thoughts or insights would be appreciated

  • Install the MSU updates on your own after downloading them – magicandre1981 Jun 14 '18 at 14:05
  • that would be not preferable as there are over 100 of them – levi Clouser Jun 14 '18 at 16:02
  • You can use WSUSOfffline to automate the process. You are likely missing required cumulative updates thus preventing you from downloading any updates released after those "required" updates. – Ramhound Jun 14 '18 at 16:19
  • KB2919355 is the April 2014 Update which is required for all new updates. MS released new ISOs which include it and the November 2014 update. So if you reinstall Servers, use the new ISOs. – magicandre1981 Jun 19 '18 at 14:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.