1

I have a Micro SD card inside a USB 2.0 adapter that is not working.  I have tried a few different methods to fix my flash drive with no results. The micro SD card is 32 GB inserted into a USB 2.0 adapter.

  • When I plug the drive into a port, Windows 7 makes a sound, and I am prompted to format the drive. I failed after a number attempts to format the drive. I tried all the ports on three different computers (same results).
  • Next, I uninstalled the USB driver and reinstalled the flash drive FAILED
  • I opened CMD, entered diskpart > select disk 1 > clean and I followed more steps that I found online but still FAILED
  • I changed the LETTER of the drive, then continued the step above FAILED
  • I tried to insert the drive into my Xbox 360 to try to format it FAILED
  • I tried four different recovery programs FAILED
  • I tried to format each sector (it took 3 hours) FAILED
  • I removed the card from the adapter and placed it into an SD card, then inserted it into my laptop FAILED
  • I tired using a micro USB adapter to connect to my cell phone to erase ALL on the drive FAILED
  • I tried to use ERASER software to delete all on the drive FAILED

The drive was working fine two days ago. It was used to store video games and add-ons on my Xbox 360 console. Two days ago, I went to play a game on the drive, but it wasn't there. In fact, the console read the drive was almost full; however, the contents was empty.

I would like to delete, erase or reset the drive so I can use it again.  I don't need to recover its contents; I can always re-download the games and stuff.

What can I do?

2
  • 1
    Yes, the solution is very simple. Open your trash can, insert the SD card, then close it. After that, buy a storage medium that is actually suitable for use with an XBox.
    – Daniel B
    Jun 14, 2018 at 20:11
  • SD cards fail. Based on the evidence you've provided, I would guess that your SD card has failed. As Daniel notes: when considering future storage options for your Xbox, I strongly advise you look at devices besides an SD card. They are simply not the best for this application. Jun 14, 2018 at 20:27

1 Answer 1

1

I would suggest to check your USB adapter for a write protect switch however you say putting just the microSD in your phone still fails so I do not see that being the cause. The most likely culprit is the flash memory is worn out and will not function anymore, however I have had success in the past by using ChkFlsh https://mikelab.kiev.ua/index_en.php?page=PROGRAMS/chkflsh_en to recover both an SD card and a USB flash drive that would fail to format.

  1. Download and right click run-as-administrator ChkFlsh from the link above (the download button is the small text above the picture of the program).
  2. Click "As physical device (NT-based systems only)", select your drive from the dropdown list, then scroll down slightly and select "Low level initialization."
  3. VERIFY YOU SELECTED THE CORRECT DRIVE! This tool can and will wipe whatever device you point it at.
  4. Click Start. Click Yes on any warning that comes up (there's a couple different ones depending on what it sees on the drive.)
  5. Next a window titled "Partitions" will open up, select partition 0 and click New, on that window that pops up just click OK. (Even if it selects a filesystem you don't like, just use Windows later to reformat it to what you want.)
  6. Click Yes to write all changes to disk and when asked replug the device without unmounting/safely removing it.

If, and that's a big if, your microSD card is repairable this will have done it and you should have a formatted empty microSD card. If it still doesn't work it can function as a table drink coaster for a tiny mouse family, or just toss it in the trash.

1
  • I followed the steps with the results of 72 plus 'device write errors' Anyone want a tiny coaster? LoL thanks guys but no good results. I'll buy a new one
    – Varoon
    Jun 15, 2018 at 1:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .