For years I've been using the ahk script below to disable the WS_CAPTION (long 0x00C00000) flag on Windows 10 applications windows in order to make their title bars invisible. The most common case of usage is for chrome apps opened as window.

LWIN & MButton::
MouseGetPos,,, WinUMID
WinSet, Style, -0xC00000, ahk_id %WinUMID%

I'm not sure if it's because of my Windows update or Chrome update, but this does not work for chrome apps opened as windows anymore. It still does work for other applications, though. I'm pretty sure there is no problem with my script, because I never change it. Also, my AutoHotKey didn't update, so I guess there is no problem with it as well. I've filled a bug report for chrome (I think they don't provide reporters an url), even though I'm not sure it's their problem. Does anyone also have this issue or know what could cause it?

As asked by 3D1T0R, here's a screenshot of a current window that this script used to work on. screenshot of a current window that this script used to work on

Thank you very much.

  • What versions are you running of Windows and Chrome? (For Windows, please supply Edition, Version and Build #.) Also, is there any chance you could add a screenshot of a window that you would do this to? – 3D1T0R Jun 15 at 18:12
  • Chrome stable channel 67.0.3396.87 64bits – Logerfo Jun 15 at 18:39
  • Windows 10 Pro Version 1803 Build 17134.112 – Logerfo Jun 15 at 18:40
  • Is this your problem : Google will end support for Chrome apps? The article says: "come early 2018, you'll no longer be able to load Chrome apps". – harrymc Jun 21 at 21:05
  • @harrymc not at all. it's not real apps. You can drag and drop a url to the chrome://apps page and check the "open as a window" option. That's what I mean. – Logerfo Jun 22 at 1:18

I used Window Detective to select the Chrome window (normal window and not an app).

This tool allows to edit the window's styles, so I used it to delete the WS_CAPTION style a couple of times.

The result upon clicking the Set button was a flicker, and sometimes the Chrome window itself moved slightly on the screen, but the caption stayed.

Upon re-examining the style after the change, I found that the WS_CAPTION style has been returned to the Chrome window.

My conclusion is that recent versions of Chrome now detect the change in style and reset it immediately back to what it was before.

I am afraid that you are up against Chrome not allowing such changes. If I am right, you may need to move to another browser, or to accept that the caption is unavoidable (at least until some future time when maybe this will change back). A lame alternative would be to move the Chrome window so that the caption is positioned off-screen.

You may raise the question in the Chrome forums, asking for this to be reversed, but your chances may be slim.

  • I wish i could find the exact chromium commit where this has been broken, but the repository is super active. Another alternative may be to reinstall an old version and stick to it. – Logerfo Jun 22 at 14:21
  • If you are into Chrome sources, try to search for WS_CAPTION. – harrymc Jun 22 at 15:23
  • I guess you're having the bounty since it's the only option besides keeping it open – Logerfo Jun 22 at 18:24
up vote 1 down vote accepted

I managed to solve the problem by deactivating the #windows10-custom-titlebar flag at chrome://flags and restarting the browser. Thanks everyone who replied.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.