0

One of the machine on my network suddenly cannot resolve DNS names anymore (all other machines are fine).

  • It's on Windows 10.
  • It can ping any IP successfully.
  • DNS was working, no user made any change, and then it stopped working. The only thing that happened in between was a forced Windows update (v. 1803).
  • "NSLookup google.com" times out

After consulting various online guides, here's what I've tried:

1. Flushing DNS and renewing

  • ipconfig /flushdns
  • ipconfig /registerdns
  • ipconfig /release
  • ipconfig /renew

2. Configuring

  • Letting the DHCP server manage the DNS for IPv4 and IPv6
  • Manually setting the DNS to 8.8.8.8 (which I can ping successfully)

3. Repairing TCP/IP Stack

  • netsh int ip reset resetlog.txt
  • netsh winsock reset catalog
  • netsh int ipv4 reset reset.log
  • netsh int ipv6 reset reset.log

4. Rebooting

  • Rebooting the machine
  • Rebooting the router

5. Network Reset

  • Windows 10 Network Reset feature

6. Clean boot

  • Disabling all services in "msconfig"

7. Making sure that Microsoft LLDP Protocol Driver is enabled

8. Reinstalling network adapter drivers

9. Disabling the firewall (temporarily)

... so what's next ?

  • "a forced Windows update." Which one? – Moab Jun 16 '18 at 13:22
  • See if any of the commands in this link help....windowsreport.com/dns-issues-windows-10 – Moab Jun 16 '18 at 13:23
  • Edited to add update version – Philippe Carriere Jun 16 '18 at 13:34
  • @Philippe Carriere, this may be a silly question, but have you tried resetting the TCP/IP stack? – Tim_Stewart Jun 17 '18 at 17:00
  • @Tim_Stewart Do you mean my step 3 (Repairing TCP/IP Stack) or are you talking about something else ? – Philippe Carriere Jun 18 '18 at 18:02
0
  1. Try going to a Command Prompt and running "NSLookup google.com", as that may handle DNS differently. (Why do you think DNS doesn't work?)

  2. See if your HOSTS file has been modified.

  3. Check Services.MSC and ensure that any service starting with "DNS" or "Domain" is Started.

  4. See if other machines on the same network have the same problem. (If you have a compromised router, it could corrupt DNS packets as they go through.)

  5. Completely disable Windows Firewall. (This is not a recommended long term fix, and could potentially open up some security vulnerabilities. However, a firewall can potentially block outgoing traffic, and I've had a number of times when this solved things.) If this resolves things, re-enable Windows Firewall to get that protection back quickly, and focus your further troubleshooting efforts on figuring out which Firewall rule is causing an issue.

  • "NSLookup google.com" times out. My host files has not been modifed. DNS client is running. As stated, all other machines on the network are fine. – Philippe Carriere Jun 16 '18 at 14:10
0

I reinstalled Windows. It didn't fix the problem. Network is working perfectly but no DNS.

I changed the network card: problem fixed.

For good mesure: Putting the old card back in will produce the problem again, and switching to the new card fixes it every time.

  • I still fail to understand how broken hardware can lead to a perfectly running network with the exception of name resolving. Isn't DNS purely software ?? – Philippe Carriere Jun 20 '18 at 2:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.