1

Suddenly, likely due an update, input is corrupted for ASCII chars. I am using Windows 10 (Version 1803, Build 17134.112).

Usually if I write left Alt + 254 on numeric keyboard I got black square ■ but now I am getting replacement character �. Similar applies to other ones.

Any solutions?

  • What OS? What update? – Spiff Jun 17 '18 at 21:49
  • @Spiff: Updated. – Ucho Jun 17 '18 at 21:53
  • ■ is what I get when I type in Alt+254 so your updated Windows to version 1803 and then now when you type in Alt+254 now you get the � character instead? Have you already rebooted the PC just in case it's something simple or else wonder what language your system is setup with exactly? – Pimp Juice IT Jun 20 '18 at 0:27
  • This applies to all chars from 128 to, it seems, 255. I am using Czech and secondary English. You can see on asciitable.com that 125 is normally } and 254 is ■. – Ucho Jun 20 '18 at 19:38
1

The cause was in the setting that I set some day. Specifically, “Use Unicode UTF-8 for worldwide language support”.

enter image description here

|improve this answer|||||
  • Huh, that's an interesting setting. (Good idea a few decades late?) – user1686 Jun 25 '18 at 14:37
  • @grawity: I dunno what that should do but definitely on my Windows 10 settings this beta feature works bad. – Ucho Jun 25 '18 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.