This is a problem that emerged a few months ago and couldn't find a solution for, the favorite keys do not work anymore in their normal use.

By normal use, I mean pressing the key to open the program in task bar; if you hold the key to show pinned items or hold Shift to start the program as administrator, they all work.

So it is definitely not a hardware issue, the keys are all working.

Here's a screenshot showing the faulty keys in blue:

enter image description here

I have tried the following without success:

  • un-install, reboot and re-install the software
  • disable all startup programs to see if any are conflicting
  • fresh install of Windows 10 (April update)

By looking at mskey.exe, there is definitely something wrong as Ctrl is being emitted by the key, obviously this won't work even when tried for real:

enter image description here

Has anyone experienced the same issue and found a fix for it ?

  • Does this happen when booting in Safe mode?
    – harrymc
    Jun 20, 2018 at 5:55
  • Yes it does happen in safe mode.
    – aybe
    Jun 20, 2018 at 7:58
  • This is then a problem within Windows itself. I suggest to go into Device Manager and delete the keyboard device, then reboot using the mouse. This will clean-install the driver and may fix the problem without side-effects. If this doesn't help, download and install the driver from here.
    – harrymc
    Jun 20, 2018 at 12:45
  • I believe so but this is also happening on a fresh install. Also, I've already tried what you've mentioned but without success.
    – aybe
    Jun 20, 2018 at 22:33
  • Has something changed on your computer when this started happening, hardware or software? Can you try the keyboard on another computer? If this also happens on another computer, then this is a hardware problem after all.
    – harrymc
    Jun 21, 2018 at 7:55

1 Answer 1



Microsoft® Mouse and Keyboard Center 10.4 finally solves the problem !!!

I ultimately ended up with five AutoHotKey scripts that work rather well. I've lost the functionality of pinned items but since they require both hands for selection, I guess it's okay to press an extra key with the hand.

The most important part is working and that's a good thing, because switching hundreds of time per day to different programming software, you can imagine that typing thrice as much keys is extremely boring to say the least.

For ones who might have the same issue, here's the first script:

#SingleInstance force

SendInput {LWin up}{Alt up}{1 up}{2 up}{3 up}{4 up}{5 up}
Sleep 100

SendInput {LWin down}{1 down}
Sleep 100
SendInput {1 up}{LWin up}


Change the last block key for the four other scripts, compile as EXE with Ahk2Exe and you're set !


After trying to track down the cause of the problem, to me, Windows Version 1709 (Fall Creators Update) has introduced a regression inducing this problem. It is roughly at this time that I've started encountering this problem (I do install updates as soon as they become available).

Tried on Windows 7 and they effectively work as expected, one mystery though, the Ctrl key is also emitted but seems to not be ignored anymore on a recent Windows 10 version, therefore causing these keys to fail.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .