Is there a way to prevent Google Chrome from automatically downloading and playing flash videos?

I am using limited mobile data plan and such videos are wasting a lot of MBs.

  • 1
    Google for Chrome prevent automatically playing flash videos and check first few options. – Sandeep Jun 18 '18 at 9:03
  • 2
    Are you sure they're Flash and not more standard formats (e.g., mp4, webm)? – jpmc26 Jun 18 '18 at 14:05
  • @jpmc26 Some of them are HTML5 and pop-ups but I guess their's no single solution for all formats and types. I am using HTML5 block autoplay extension but their's still cases that it doesn't work. – Freak0345 Jun 18 '18 at 14:20

Go to the autoplay policy via the Chrome address bar.

Type chrome://flags/#autoplay-policy in the address bar.


The Autoplay policy should be set to Default when you load the page. You’ll need to set the drop box option box to Document user activation is required so that you have to approve any video to play on a website.

Lastly, you’ll need to click on the blue Relaunch Now button found at the bottom of the page. This will restart the Chrome browser and activate the change.


This worked for me, Version 67.0.3396.87 (Official Build) (64-bit).


In the Chrome menu, go to settings and scroll down to Show Advanced Settings.

Click this and under the Privacy heading, click Content Settings.

In the pop-up window, scroll down to Plug-ins and select the Click to play radio button.

Chrome plug-ins settings

Source: How to Stop Auto-Playing Flash and HTML5 Videos in Chrome

  • 4
    What version of Chrome does this apply to? I do not think your answer is accurate. – MonkeyZeus Jun 18 '18 at 16:18
  • 2
    Note this is likely out of date if you're using an updated Chrome. Article is from 2014. – BruceWayne Jun 18 '18 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.