1

I am trying to start a XServer in order to perform graphical renderings on the cluster GPU with Paraview. Since the cluster is usally driven by a task scheduler, the xserver is usually not running. For visualizations I need to start a Xserver in combination with the Paraview server.

If I try to start the XServer manually with

xinit 

I recieve the following error message:

(EE) 
Fatal server error:
(EE) PAM authentication failed, cannot start X server.
Perhaps you do not have console ownership?
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
 at http://wiki.x.org
 for help. 
(EE)

I tried to use xclock from ssh -X and that works. If I try glxinfo then it won't work.

I am logging in from a remote machine via ssh. Any suggestions?

0

I had the same problem. In my case I solved by changing the file /etc/pam.d/xserver.

Change the line auth required pam_console.so to auth sufficient pam_permit.so

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.