0

Restarting my computer one day, most of my files in my folders were switched to read-only. I've changed the permissions to allow everyone full control, as well as going through each user.

enter image description here

After doing all that, as well as going to the properties and flipping off the read-only radio button (which resets itself back to the on position), my problem still hasn't been fixed.

I've been reading through this Q&A site to try to find the answer, and I'm hoping someone can help me.

Edit: I am running window 10 Pro. I wish I were savvier then I am so I would know what is relevant or not.

  • Windows Defender has a feature that protects a folder from any changes. What build of Windows 10 are you using? If you boot into Safe Mode do you have the same problems? Please edit your question to include any additional information that might be helpful – Ramhound Jun 19 '18 at 2:10
  • What should i look for in windows defender to change the settings? – mr5x5 Jun 19 '18 at 2:54
0

Look at Windows Defender Security Center:
1. Double click the Windows Defender icon in system tray (bottom right corner of the screen),
2. Choose Virus & threat protection setting > Controlled folder access (Manage controlled folder access).
It's security feature from Windows Defender against Ransomware attacks. Just disable Windows Defender or Add the program to exclusion setting.

| improve this answer | |
  • So I am running Avast anti-Virus so imagine that windows defender would be switched off? After attempting to complete this, I get a message from Windows defender stating, " Your IT admin has limited your access to this app." and therefore the controlled folder access is not there. – mr5x5 Jun 19 '18 at 12:33
0

The problem isn't well documented online since there are multiple causes and very few are known.Assuming Windows 10, here are some solutions:

  • Controlled Access Switch: The quickest no frills solution is through Windows Defender (this worked for me)

    1. Launch Windows Defender

    2. Navigate to 'Virus & threat protection' setting

    3. Switch off 'Controlled folder access' (this limits privileges on changes made by users and programs on System folders ie Documents, My Music etc)

  • Checking and changing file permissions

    1. To check file permissions, type the following in PowerShell:

      (get-acl <folder name>).access | ft IdentityReference,FileSystemRights,AccessControlType,IsInherited,InheritanceFlags -auto
      
    2. To change file permissions, type the following in PowerShell:

      takeown /f <directory> /r /a
      
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.