1

I have a Windows 10 Home machine (Lenovo Y520) with a Core i7-7700HQ processor. Windows 10 and the BIOS are up to date. So is Oracle Virtualbox.

Until recently it was running VMs just fine with Oracle Virtualbox (doing what I bought it to do). Then it stopped doing that. VirtualBox's New VM feature stopped offering me 64-bit VMs. The ones I already had in place stopped running.

I have tried the instructions in these answers:

Why does virtualbox only have 32-bit option, no 64-bit option on Windows 7?

VT-x is not available, but is enabled in BIOS

Specifically, I've tried upating the BIOS, reloading BIOS default settings, turning on Intel Virtualization in the BIOS, rebooting, powering off and back on again, etc etc ad nauseam. W10 Home doesn't have the Microsoft virtualization features that often interferes with VirtualBox, and I've made sure Windows Hypervisor Platform is shut off.

Still, no 64-bit vms. What next?

1

VMWare Player gave a better diagnostic response than VirtualBox did when I tried to create a 64-bit virtual machine.

It said that my machine had the enterprise features Device Guard and Credential Guard enabled. I suppose they became enabled when I ran MalwareBytes; I can't think of any other change I made.

VMWare Player pointed me to a page called Manage Windows Defender Credential Guard. That page has a bunch of stuff about Group Policy Manager settings and the like, which of course are irrelevant to a W10 HOME installation.

In turn, that page pointed me to the Device Guard and Credential Guard hardware readiness tool, a PowerShell tool for enabling and disabling this feature set on servers.

Running that tool in a Run-As-Administrator power shell and giving this command

 .\DG_Readiness_Tool_v3.5.ps1 -Disable -AutoReboot

took me through the process of disabling those features.

And I have virtualization capability back.

  • "Malicious code refers to a broad category of programs that can cause damage or undesirable effects to computers or networks" - most av and am software ive tried fits this description - most av don't allow you to ignore files effectively so will randomly delete files which I want - why don't they clearly explain wtf they are doing to your machine. – SwiftD Jun 19 '18 at 12:43
  • @SwiftD can you please explain how this is relevant to the present issue? – O. Jones Jun 19 '18 at 15:27
  • you described how installing malware bytes resulted in virtualbox stopping working - sounds like and undesirable effect on your computer - much like the definition of malicious code it prevents – SwiftD Jun 19 '18 at 15:38
  • I'm not sure about the MalwareBytes cause for my problem. I needed MalwareBytes because I got a virus warning (that turned out a false positive.) That software generally does a good job of scrubbing malware. – O. Jones Jun 19 '18 at 21:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.