1

I had rEFInd running fine previously. Then I updated to Mac OSX Mojave beta. After the update, rEFInd was missing.

So I just reinstalled it. However, it didn't work.

Went back to 10.13.5 fresh install and installed rEFInd. I still didn't work.

I tried everything, but I can't get it to work anymore. And the strangest thing is I can't even boot off a Linux USB drive. When I click on "EFI Boot" the MacBook starts Mac OSX.

So I installed Windows 10 with Boot Camp. That worked. Installed EasyUEFI there and added rEFInd to the system. Still didn't work.

The filesystem is APFS.

Does somebody know what the problem is?

  • What version of rEFInd? Were you already using APFS prior to Mojave? – Tetsujin Jun 22 '18 at 8:01
  • I'm having the same issue. Hoping to get an answer... I believe my version of rEFInd was 0.11.1 and then I tried updating it to 0.11.2 and it still doesn't work. – jimmyplaysdrums Jul 8 '18 at 3:44
0

Probably a bug with the Mojave beta.

Placing efi shell to /usr/standalone/i386/boot.efi location and using system prefs to reboot into target volume (which will rebless the partition) helps to get efi shell booted.

Read more about it here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.