I'm trying to repair an existing Windows XP installation. Following the instructions from http://www.microsoft.com/windowsxp/using/helpandsupport/learnmore/tips/doug92.mspx this should work:

  1. When the Press any key to boot from CD message is displayed on your screen, press a key to start your computer from the Windows XP CD.
  2. Press ENTER when you see the message To setup Windows XP now, and then press ENTER displayed on the Welcome to Setup screen.
  3. Do not choose the option to press R to use the Recovery Console.
  4. In the Windows XP Licensing Agreement, press F8 to agree to the license agreement.
  5. Make sure that your current installation of Windows XP is selected in the box, and then press R to repair Windows XP.
  6. Follow the instructions on the screen to complete Setup.

On step 5 pressing R does nothing and there is nothing on the screen saying it would. When I just select to install I get a message that a previous installation is there and proceeding will destroy it and installed applications, I can optionally select a directory other than c:\windows, and I can optionally format before continuing. I had tried to go from SP2->SP3. It failed, and then I couldn't get to Safe Mode. I put the SP1 disk back in to do a repair, and I don't see that option. (I don't have an SP2 boot/install disk, I just have the non-boot upgrade package.)

UPDATE: Upon loading the Recovery Console, I get a message saying The system registry does not appear to have an active ControlSet key. The system registry may be damaged. You can try restarting it with the Last Known Good configuration or you can try repairing the installation of Windows using the setup program's repair and recovery options.

  • I then did bootcfg /scan -

    "successful" ... Total installs: 1 ... [1] c:\windows - with the c:\windows command prompt below it.

  • bootcfg /list gives [1] Windows XP Pro; OS Load Options /noexecute=optin /fastdetect; OS Location: c:\windows

  • I followed the instructions at http://michaelstevenstech.com/XPrepairinstall.htm - "Warning 2" link

    copy E:\i386\ntldr C:\
    copy E:\i386\ntdetect.com C:\
    attrib -h -r -s C:\boot.ini
    del C:\boot.ini
    BootCfg /Rebuild
    I added /fastdetect when it asked for options. I re-ran Windows setup - no change - no repair option.

I followed the procedure at http://support.microsoft.com/default.aspx?scid=kb;en-us;307545

  1. I rebooted. I now get a quick message on bootup to select the boot - 1: [blank] ; Windows XP Professional ; Windows Recover Console. The "1: " is new. The rest is the way it was when all was okay. Selecting 1: and the next one gives the same result - I get to a login icon, and then it asks for a password, with the blinking cursor, but I can't type anything. I reboot with the Windows CD. Now I see a repair option for installation "1: " I selected R on that, and it did "Setup is copying files..." and rebooted when it was done. Then it booted, and I got a window saying "Setup will complete in approximately 39 minutes." That's where I am now. I wasn't expecting this last part - I did a repair several months ago and I don't recall that.

Booted up. Asked if I wanted to register Windows online. All my icons are there, and the old desktop documents. Good. All the applications I tried from the Start Menu work (tested a few), except Corel Photopaint - I get registry entry not found errors. Windows ran for a while, then froze. The mouse and keyboard don't work. Pressing the power button got Windows to shut down. I probably need to put SP2 on it, and then all the updates for my laptop for XP Pro SP2 (drivers), there's a bunch. The mouse and keyboard quit working again. That wasn't a problem when I first set up this laptop. I've ran 4 times now. Two mouse/keyboards hangs by pressing Ctrl-C (to copy text from a notepad document), and two by selecting Start-Run (wasn't able to type anything in the box).

  • @Jason: What exactly do you get on the screen for step 5? Did you try booting into the Last Known Good configuration?
    – harrymc
    Apr 21, 2010 at 15:24
  • The two NTFS partitions - neither saying there's Windows there. It's on partition 1. When I select that it says there's already "some" O/S there, and continuing will destroy it. I haven't seen a Last Known Good configuration option anywhere.
    – Carl
    Apr 21, 2010 at 15:45
  • See the new UPDATE in the question (the 2nd/last one).
    – Carl
    Apr 21, 2010 at 15:59
  • Another UPDATE in the question.
    – Carl
    Apr 21, 2010 at 17:02

2 Answers 2


Sounds like your hard drive is faulty.

If so, this could have caused your registry to get corrupted originally (hence the Repair couldn't find the active Windows install). You hacked it back into a mostly working mode, and then it froze, again, very likely caused by a faulty drive.

Have you run CHKDSK (or alike) against it to see if it says it's OK? You can run CHKDSK from the Recovery Console.

If it's not OK then you'd best get any data you want to keep off of it (via something like a bootable Linux LiveCD, or perhaps UBCD4Win) before it totally gives up the ghost.

  • I've been using the hard drive externally for 2 months with my other laptop. I ran chkdsk early on - no errors. I don't think it's a coincidence this happened when I tried to -> SP3.
    – Carl
    Apr 21, 2010 at 22:14

You may be using the incorrect Windows XP setup disk or version. Try using a home edition CD instead of a Professional CD or vice versa.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .