74

A couple of days ago I noticed that for all websites, chrome omits from the address bar the protocol and the subdomain if it is www. My co-workers report that they are not seeing this. Chrome version is 67.0.3396.87.

For example, if I type into the address bar https://www.google.com (without the quotes), Chrome immediately displays the chip "Secure" followed by google.com. See attached screenshots.

what I enter

what Chrome displays

I have looked in vain for Chrome settings that affect this, plus the chrome://flags page and chrome://net-internals page.

I did not do anything consciously to make this change.

Any ideas?

EDIT: Suggestion from MrWhite that Ominbox UI Hide Stead-State URL Scheme and Trivial Subdomains had become enabled: good suggestion, except that the setting is still at “Default.” See screenshot:

Omnibox UI Hide Steady-State -- still set to Default

However, as a shot in the dark, I am going to play with the setting to see what happens.

First I set it to “Disabled.” That restored the previous behavior of the address bar, which is to not to hide the protocol and “trivial subdomains.” Then I changed it back to “Default,” and it was hiding them again. One would suspect that somehow the default has been changed, except that co-workers are not reporting this issue.

Oh, well. I’ll just leave it as Disabled for now.

I would be ready to accept the answer from MrWhite, because it provides a workaround. Yet will leave it open for a bit longer, because it does not really answer why this behavior has changed, and why it has to be overridden.

EDIT 2: Chrome version is 67.0.3396.87.

  • 1
    What version of Chrome are you using? – MrWhite Jun 25 '18 at 19:21
  • Please provide what your version of Chrome is, and maybe even ask your coworkers what version they have. It could be that yours was updated, but theirs are not. – mbomb007 Jun 25 '18 at 20:28
  • 1
    Noticed that, while I already changed this setting to "disabled" before, after updating to 76.0.3809.100, they reset this to default value again. They're pushing this misfeature so aggressively. – kolen Aug 13 '19 at 15:46
  • Does this answer your question? How do I show www. and https:// in Chrome 79? – Mawg says reinstate Monica Dec 19 '19 at 7:00

10 Answers 10

54

UPDATE March-2020: The chrome://flags option listed below in my original answer no longer works as the flags appear to have been removed from the UI (although for some time after they were visibly removed from the UI, the options did still appear to persist if you had previously disabled these features in the UI - although this is no longer the case).

However, as stated in comments by @RIanGillis you can still disable these options on the Chrome shortcut / command line by adding the --disable-features argument. For example:

.../chrome.exe --disable-features=OmniboxUIExperimentHideSteadyStateUrlTrivialSubdomains,OmniboxUIExperimentHideSteadyStateUrlScheme,OmniboxUIExperimentHideFileUrlScheme

This appears to restore the original functionality for me (tested Chrome v80.0.3987.132). http:// is still hidden (and shows "Not secure" instead). https:// is shown as are www subdomains.

Another option, as stated in @wOxxOm's answer below, appears to be to install Google's Suspicious Site Reporter extension which also gets the protocol and subdomains back.


ORIGINAL ANSWER (No longer works):

The behaviour you are seeing is consistent with having the "Omnibox UI Hide Steady-State URL Scheme and Trivial Subdomains" setting enabled within chrome://flags.

Chrome Flag - Omnibox UI Hide Steady-State URL Scheme and Trivial Subdomains

Returning this flag to "Default" (or "Disabled") and restarting the browser (prompted) should get your scheme + subdomains back. This is on Chrome Version 67.0.3396.87 (Official Build) (64-bit) - Windows.

Except checking that setting does not show "Enabled"; rather it shows "Default".

As far as I can gather, whether "Default" means "Enabled" or "Disabled" is built-in to the Chrome executable. So, this is primarily version dependent. Note also that settings vary between "Developer" and "Stable" builds.

Settings can also be enabled/disabled in command line switches. So this is another area that is worth checking. Reference: https://peter.sh/experiments/chromium-command-line-switches/ - although I don't see much relating to the Omnibox in this list.


UPDATE Sept-2018: As noted in another answer, from Chrome Version 69 (tested Version 69.0.3497.81), this feature now seems to be enabled by "Default". So, you must explicitly set this to "Disabled" to remove this feature.


UPDATE Aug-2019: This option/flag has since been split into two (possibly since version 72 - according to @Kyborek in comments):

  • Omnibox UI Hide Steady-State URL Scheme
  • Omnibox UI Hide Steady-State URL Trivial Subdomains

The "Default" setting is enabled, so these options must be explicitly set to "Disabled" to get the "Scheme" and "Trivial Subdomains" back in the URL address bar. (Note that the insecure "http" scheme/protocol is always hidden, regardless of this option.)

Chrome Flags - Omnibox Hide Scheme and Trivial Subdomains

There is also a new(?), rather ominous, option: "Omnibox UI Hide Steady-State URL Path, Query, and Ref" which currently (Chrome version 76) appears to be disabled in its "Default" state. Something to keep an eye on though!

Chrome FLag - Omnibox UI Hide Steady-State URL Path, Query, and Ref


UPDATE Nov-2019: Unfortunately, it seems that since version 78 these flags have now been completely removed from the UI.

However, whilst these flags appear to have been removed in the UI, if you have previously disabled these flags in an earlier version then the options appear to stick and the "trivial subdomains" and "(HTTPS) URL scheme" remain visible.

| improve this answer | |
  • 3
    I have to set it to "Disabled" to restore how it has always worked up until a few days ago. – Jeffrey Simon Jun 26 '18 at 19:59
  • 1
    Whatever "Omnibox UI hide..." I disable, it still hides plain http. – Ivan Feb 19 '19 at 10:17
  • 1
    In Chrome version 73+ this setting is now named Omnibox UI Hide Steady-State URL Trivial Subdomains in case you want to search for it – Kyborek Feb 19 '19 at 13:32
  • 13
    I am on Chrome version 78 and those flags were completely removed. – Chris Nov 3 '19 at 17:54
  • 3
    @MrWhite OK, but how do I disable these flags now, that they are not visible in Chrome anymore? Update: found the solution. First, enable "Temporarily unexpire M76 flags" option, restart chrome, then those flags will appear again. Looks like they're going to be removed in future versions of Chrome forever, though :( – izogfif Nov 22 '19 at 9:59
38

The chrome://flags entries are temporary and will be removed in the future versions of Chrome.

The current solution in Chrome 83+

Right-click inside the address bar and enable "Always show full URLs" in the context menu. If the option isn't there, go to chrome://flags, find show full URL flag, enable it, restart Chrome. Hopefully, it'll be present by default in the future, see crbug.com/1061576.

enter image description here

The alternative official long-term workaround

The officially supported long-term workaround is to install Google's Suspicious Site Reporter extension.

  • www and other "trivial subdomains" will be shown fully
  • https:// will be shown fully
  • http:// will be hidden, Not secure will be shown instead

It works because Chrome/Chromium explicitly checks whether the extension is installed and enabled using its id and toggles the URL elision feature accordingly.

  • For those who don't want to install Site Reporter extension.

    The only required part of that extension is an excerpt from manifest.json shown below, no other files needed. You can install it in your browser as an unpacked extension. It should be trivial to install on Linux or MacOS. As for Windows, only the Canary channel supports unrestricted installation of unpacked extensions as far as I know. Some Chrome forks support it too. In the official stable Google Chrome on Windows you will have to use an elaborate trick to avoid a warning on each browser start.

    This zero-weight extension uses the same id as the Google's extension so you can't have both of them installed, but you only need one anyway. Note, since the id is the same we can't upload it to the Web Store.

    1. Copy the following text and paste it in your text editor, save as manifest.json.
      See also How to save files with any extension in Windows
    2. Open chrome://extensions page, enable "developer mode", drag'n'drop the directory with manifest.json into the page or click "Load unpacked" button and indicate the directory there.
    {
       "name": "Keep full URL",
       "description": "Prevent elision of www and other trivial subdomains in the address bar",
       "version": "1.0",
       "manifest_version": 2,
       "key": "MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAowA8wOUQ8ShyITJ15B9rcJrnoolyo+OLj07g8QWBlEBikgszYwlbc88OIRL+dJOASok3yG6RQ60fvIjBrtNEk1yQZJfNwF/CN0jFrkE3HN3xVMoX0XIQPB93kDZARcfR5nwU3RUgwwWGTqt69KSSU8QzRRQJSEgM8GENa3OBhw1UBn/I/RbhaFcTykJSomo9j55goJwNzUhXTJk458DQ5diY+gWMadDXlDBa8cciCVlaGOjBV5ezmxnD6p1GXhrvyEKZP8IlreDJC2Nw9hxrT3GIo1FzbmeDPANKJ9pkY1H3LOVsGJDtytBpD/FRErlvfkJVqp3N5ifF2EQ8lOAHrQIDAQAB"
    }
    
| improve this answer | |
  • well my mistake and your answer is complete. and you thought of everything – theggputest55 Dec 19 '19 at 14:30
  • I tried this and it doesn't work, using Version 80.0.3987.116 (Official Build) (64-bit). I'm ditching Chrome for good now and start using Vivaldi which doesn't have this stupid behaviour. – Dediqated Feb 21 at 11:32
  • @Dediqated it works for me in Chrome 80-82 and it should work for everyone because the source code of Chrome/Chromium didn't change in this regard. – wOxxOm Feb 21 at 11:37
  • IMO, this should be the accepted answer now/since Nov-2019, after Google removed the flag. based on the extension's name I don't have enough trust in Google to believe that it won't send data when I'm browsing normally. – Wis Feb 28 at 18:47
  • For the laziest of the lazy I've made a repo from this response: github.com/armarti/ChromeExtensionShowTrivialSubdomains – dcmorse May 7 at 2:57
8

It is now default setting for chrome://flags/#omnibox-ui-hide-steady-state-url-scheme-and-subdomains

It will now also strip some other subdomains like "m.domain.com" to "domain.com", so "www.m.www.m.example.com" will show up as "example.com" in address bar unless "Omnibox UI Hide Steady-State URL Scheme and Trivial Subdomain" is set to disabled in Chrome 69

https://bugs.chromium.org/p/chromium/issues/detail?id=881410

| improve this answer | |
  • 4
    year 2020… Google removed this flag, so this option it's not working any more :( – iiic Jan 15 at 10:04
2

Additionally to the existing answers it keeps to mention that changes in the browser settings are not really required to get access to the full URL. Simply double-click in the URL-bar and you'll see it completely.

| improve this answer | |
2

The chrome://flags/#omnibox-ui-hide-steady-state-url-trivial-subdomains has unfortunately been removed in Chrome 76, but there is a very easy trick to show the protocol and subdomains again.

All you have to do is to install Google's Suspicious Site Reporter extension from the Chrome Store and the "https://www." will start showing in address bar.

omnibox


As we can see in the source code, the protocol will not get hidden if this extension is installed:

enter image description here

enter image description here

| improve this answer | |
1

Here is what's needed to get the scheme (aka protocol) and 'trivial' subdomains to be shown on Mac OS 10.13.6 running Chrome 70.0.3538.67:

  • chrome://flags/#views-browser-windows set to enabled
  • chrome://flags/#omnibox-ui-hide-steady-state-url-scheme-and-subdomains set to disabled
  • chrome://flags/#upcoming-ui-features set to Default or disabled.
| improve this answer | |
  • 1
    Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Oct 23 '18 at 20:14
1

Navigate to chrome://flags/ and set these three flags to "Disabled":

chrome://flags/#omnibox-ui-hide-steady-state-url-scheme

chrome://flags/#omnibox-ui-hide-steady-state-url-trivial-subdomains

chrome://flags/#omnibox-ui-hide-steady-state-url-path-query-and-ref
| improve this answer | |
1

These instructions are from https://jdtechservices.net/tools/.

The first method, which I prefer, is to add a parameter to your Chrome shortcut inside the target field:

--disable-features=OmniboxUIExperimentHideSteadyStateUrlScheme,OmniboxUIExperimentHideSteadyStateUrlTrivialSubdomains

If you are using Windows it will look like this:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-features=OmniboxUIExperimentHideSteadyStateUrlScheme,OmniboxUIExperimentHideSteadyStateUrlTrivialSubdomains

like this

Capture.png

The second method is to install an extension, but this will consume some memory:

https://chrome.google.com/webstore/detail/suspicious-site-reporter/jknemblkbdhdcpllfgbfekkdciegfboi

| improve this answer | |
  • +1 This worked for me on Chrome 80.0.3987.132 (at 15-March-2020). I also added another item to the list of --disable-features, as mentioned in an earlier comment: OmniboxUIExperimentHideFileUrlScheme – MrWhite Mar 15 at 19:57
0

In Chrome Canary (Version 78.0.3866.0 (Official Build) canary (64-bit)) on macOS Mojave I needed to disable both chrome://flags/#omnibox-ui-hide-steady-state-url-scheme and chrome://flags/#omnibox-ui-hide-steady-state-url-trivial-subdomains to get back the protocol and the (in my job not so) "trivial" subdomains.

| improve this answer | |
  • 5
    In Chrome Canary (Version 79.0.3928.3 (Official Build) canary (64-bit)) chrome://flags/ doesn't show me any of these when I search for "omnibox ui" – dentarg Oct 1 '19 at 20:29
0

Answer for Chrome/Chromium 78 and newer:

While the settings are gone from the chrome://flags/ UI in Chrome 78, there is still a way to disable this behaviour by editing the Local State setttings file. There was a howto in the Google Forums that's now censored by Google, but you can still find it in the Google Cache

Basically it comes down to

  1. List item
  2. Exit Chrome
  3. Open the file ~/.config/chromium/Local State file in an editor (path may vary dependending on OS/Install)
  4. It's a JSON file, so find the enabled_labs_experiments array in there
  5. Add "omnibox-ui-hide-steady-state-url-trivial-subdomains@2" to the list to disable subdomain hiding
  6. Add "omnibox-ui-hide-steady-state-url-scheme@2" if you want to show the protocol too
  7. Start Browser again
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.