41

I just installed Windows Server 2016 in a development virtual machine and strangely there is an 'Unknown Locale (qaa-Latn)' listed in my language / input list (in the task bar) and it doesn't show up anywhere in the 'Clock, Language and Region' and > Language areas of the control panel nor in the newer Windows Settings dialog.

I have no idea how it got there and how I would remove it as it isn't listed anywhere explicitly.

Is there any way to remove this locale?

Update with more Details: This is/was a bare bones, fresh installation (using the Feb 2018 MSDN imnge of Windows Server 2016.. and I also tried re-installing it, again.. as new installation based on the RTM version of Server 2016 standard) without any 3rd party software. The only 'special' part is that it's running as a Hyper-V virtual machine (with Windows 10 Enterprise N being the host OS).

enter image description here

3
  • 1
    I have no repo, so have to post in comment. Got same problem with Windows 10. Solution in PowerShell: Get-WinUserLanguageList - check your actual language list. $List = Get-WinUserLanguageList - assign it to a var (wraps as an array). Set-WinUserLanguageList $($List[0], $List[1]) - set language list from var, according to number of languages in your OS (2 in my case). Unknown locales should dissappear. – coffman21 Apr 5 '20 at 18:26
  • Just had it too, after upgrading to Win10 v2004. Funny however is that the 'QAA' does not appear on the task bar on the upgraded laptop itself, but in all RDP sessions on Win10 and Server 2016 I open from it. Get-WinUserLanguageList does the opposite: it does not list QAA-Latn in those RDP sessions, but it DOES list it on the upgraded laptop. – Luc VdV Jul 28 '20 at 6:19
  • PS: and I know why it happened here. Before the update, I had my locale set to 'en-BE' to combine the English language with Belgian (European) date, time and number formats. – Luc VdV Jul 28 '20 at 6:28
99

I've just gone through the hassle of removing qaa-Latn. Hopefully, this will help others and the future me. In the Admin PowerShell, type:

$LanguageList = Get-WinUserLanguageList
$LanguageList.Add("qaa-latn")
Set-WinUserLanguageList $LanguageList -Force

Then go to Settings (Win+I) / Language settings, and just remove QAA-LATN from there:

enter image description here

Or use another PowerShell script:

$LanguageList = Get-WinUserLanguageList
$Language = $LanguageList | where LanguageTag -eq "qaa-Latn"
$LanguageList.Remove($Language)
Set-WinUserLanguageList $LanguageList -Force

Updated, it just happened again after another Windows 10 update. This time I've simply reset the language list to one default language (en-US):

Set-WinUserLanguageList en-US -Force

Updated, if you also want to get rid of unwanted Win10 language packs, here is how.

15
  • 3
    Works for WIN10 Pro and "QAC-LATN" (which showed up on my Laptop) in the same way! – GWD May 25 '20 at 19:29
  • 1
    I'd also note that an elevated PROMPT is not really necessary especially since the Language settings are on a per User basis - at least on my WIN10 machine! – GWD May 31 '20 at 13:18
  • 1
    Brilliant, this works! Thanks! – fool4jesus Jun 16 '20 at 15:22
  • 1
    Worked in Windows 10 2004. You are my hero. – Neurotransmitter Sep 13 '20 at 16:14
  • 1
    Perfect... the best solution so far... i had almost the same problem but the languge was named "Qac-Latn" but the solution worked for that too – Daniyal Ahmad Oct 2 '20 at 2:39
3

Go to Language Preference, look for language qaa-Latn, add it and change Keyboard to the German keyboard then save...it will update the registry..afterwards you can delete it and it will disappear

0

I have no idea how it got there and how I would remove it as it isn't listed anywhere explicitly.

Is there any way to remove this locale?

You have a legacy Keyman keyboard installed. The simplest solution would be to uninstall Keyman and any keyboards you have installed.

The codes qaa-qtz are reserved for local use. They appear in the list at present because they are assigned to legacy custom languages (e.g. fr-ca instead of fr-fr) or non-languages such as IPA. Thanks for pointing them out; they’ll be corrected with an update to the keyboards repository.

Source

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.