20

I have a strange issue with a dual monitor, extended desktop setup where the mouse is always fine on the primary monitor, but sometimes when I move to the secondary display the icon becomes garbled and distorted (sometimes it just looks like a vertical line, instead of a pointer). If I move the mouse back and forth rapidly between primary and secondary displays the level of "garbledness" of the icon will change and sometimes go away completely. If I switch the display settings and set it to "Duplicate Monitor 1" then I end up with a garbled icon on the primary display and an accurate one on the secondary. Very annoying.

Computer is Windows 7 Ultimate with an HD5780 and the newest video drivers. Monitors are two Dell 24" displays connected via DVI cables. I have also tried VGA cables.

  • 1
    I have a similar issue (same OS, gfx-card and screens) which randomly comes and goes, except in my case its not just the mouse pointer that's garbled. – glenneroo Jan 28 '11 at 17:14
  • @glenneroo Where else are you seeing this behavior? – Nathan Taylor Jan 28 '11 at 17:22
  • My entire 2nd display. It's most noticeable with text - it seems like text is stretched/shrunken making it somewhat strenuous to read. – glenneroo Jan 28 '11 at 17:27
  • @glenneroo This sounds a little different than what I am experiencing, but could be relevant just the same. So far, ATI/AMD has ignored my bug reports. – Nathan Taylor Feb 1 '11 at 17:35
  • 1
    What happens if you leave the settings as is and then switch which monitor is plugged into which output; then you can rule out if it is a Computer-software/hardware or monitor-hardware issue. You could try uninstalling the drivers and doing a clean reinstall. Also check with the computermanufacturer/ Dell monitor to see if there is a known issue/ and Microsoft to see if there is a Win7 bug?! – Iceking007 Feb 18 '11 at 14:52
27

The problem is unfortunately an old bug with ATI cards under some multi-monitor setups that is being reported since at least 2009. I experienced it with an HD 4770. It was particularly recurring when I would host a virtual machine in fullscreen mode on my secondary monitor. But would also happen without it when I moved between screens. Just not so often.

There's no known fix at this time, Nathan. There's however a workaround:

If you enable mouse pointer trails, the corruption will go away.

  1. In your Windows 7 go to Control Panel -> Mouse -> Pointer Options Tab
  2. Enable Pointer Trails.
  3. If you don't like the effect, move the slider all the way to the left. This will make the trailing effect all but disappear.

That's it. The mouse corruption will "not" happen again. The constant redrawing of the mouse trails is effectively hiding the bug from view.

  • Had the same issue on a Geforce GT720, mousetrail was not an option since it actually leaves a short trail. Changing the pointer-theme from "none" to "windows default" fixed the issue – BobbyTables Jun 9 '16 at 8:01
  • I had this issue with an external USB graphics card. Unfortunately I don't know which chip is built into it. My question to y'all: did this bug appear right from the start after you've set up multiple monitors? In my case I didn't show up for a long time and now suddenly it's there. Any idea what causes this sudden appearance? – twigmac Aug 11 '17 at 7:50
  • From a Windows 7 64bit user thank you so much!!! I had this problem for years, the mouse trail did the trick! – Marco Demaio Jan 23 at 17:12
4

I'll add my workaround to the mix here, since they all suck a little. I've fixed the problem each time by moving the mouse to the top-right or bottom-right corner of the screen. I think by getting the mouse completely off screen, it's forcing the problem to resolve itself.

I'm using Windows 8.1 and have an AMD 7870.

  • 1
    It didn't work for me with Windows 10 and an external USB graphics card. – twigmac Aug 11 '17 at 7:52
  • It does not work on Windows 7 either – Marco Demaio Jan 23 at 17:16
3

I had this problem, too, my mouse pointer sometimes looked very trashy, like I have serious memory or display driver problems. Windows 7, dual screen, Vmware, integrated Intel display adapter, HP desktop PC. I don't think this problem is connected to any specific hardware component. The problem is with Windows and VMware, but I believe it's only in dual screen mode. Hardware doesn't matter.

My solution: Control Panel / Change how the mouse pointer looks = Mouse Properties then go to Pointer Options tab, check Display pointer trails. This is going to make the movement of your mouse pointer crazy I know, but now slide to the trail delay to the shortest. (slide it to the left)

After setting the above options my mouse pointer started to behave normally, and the the cursor distortion has gone forever! (After two PCs and two weeks I am almost sure actually) (After applying these new settings perhaps you will need to change the pointer look once)

2

Workaround: Try to enable pointer shadow (apply settings), and then disable it (apply settings). The mouse pointer should be fixed.

  • For me disabling the shadow brought the trashy pointer back BUT the mouse shadow is my preferred option to make it go away. It's just a click and doesn't really bother. :) – twigmac Aug 11 '17 at 7:56
  • On what Windows version? It does not work on Windows 7 – Marco Demaio Jan 23 at 17:19
1

I was able to immediately remove the corruption by opening my desktop -> screen resolution control panel and adjusting my side monitor's position, accepting changes, then moving it back to where it was and saving changes again. The process of recycling the display shook the garble off the cursor for me.

  • On what Windows version? It does not work on Windows 7 – Marco Demaio Jan 23 at 17:23
0

Having had the same issue with AMD FX-8350 / CLUB 3D RADEON HD 7870 ROYAL KING. The cursor will randomly become distorted on 2nd display. The only workaround I have found, apart from the mouse trail one, is:

Create Monitor Group in Catalyst (you now have ''1 monitor'' with an effective res. of 3840x1080) (if u use full HDs) and keep Vert. Sync on. Problem gone.

0

If you are using Virtual Desktop Interface (VDI) take the following step: Power-off the VDI-router box, count to five, and power it on again. The pointers on both primary and secondary monitors return to their normal arrow shape. (FYI: Restarting your VDI-session will not help; the text-select or garbled pointer will persist; you need to power-off/on the physical box; you will of course be required to log back in to the VDI).

  • Where does the OP say they are using VDI? – DavidPostill Jan 13 '16 at 17:12
0

Here is another solution that hasn't been stated and is a bit better than setting mouse trails, etc.

On the host computer, create a text file called config.ini in the "C:\ProgramData\VMware\VMware Workstation" folder. If this folder does not exist, create it.

Add the following line to the file:

mks.noHostCursor= "True"

Save the file and relaunch your VM. The mouse should be back to normal.

0

I was getting this problem with a new NVIDIA GTX 1080. It went away when I turned of cursor shadow, and came back when I turned on cursor shadow.

  • On what Windows version? It does not work on Windows 7 – Marco Demaio Jan 23 at 17:23
  • This is indeed windows 7. Problem only started when I put in the new graphics card. This problem seems to have gone since I updated the NVIDIA driver from 417.22 to 417.71... – Sanjay Manohar Jan 24 at 21:20

protected by Community Mar 4 '17 at 22:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.