My current laptop is running Linux Mint 18.2. I want to change it to Windows 10, but I'm unable to do so.

I created a bootable USB drive with a Windows 10 ISO image from here.

I followed the steps here:

I tried to format the partitions but I'm unable to install Windows. It says that there is a missing media driver:

Error screenshot

I tried to change the USB port as suggested here

but it still won't work.

1 Answer 1


I usually get that error when the hard drive I am trying to install Windows to doesn't have the msdos partition table.

(This Usually happens if a hard drive has been wiped.)

If you have a live Linux disk or USB that has Gparted installed (such as Linux Mint) Boot the PC from the Linux live disk and open Gparted. (the Gnome partition editor) and select the hard drive (usually /dev/sda) and click on the "Device" tab and choose the option to install a partition table. (The default should already be set for msdos) After Gparted creates the partition table (takes only seconds) you can reboot to the Windows installer disk or USB.

You shouldn't have to do anything more in Gparted than that as Windows will now have a working partition table to be able to create partitions and install Windows to.

Best of luck!

  • I installed the partition table as you mentioned, but sadly, still missing media device...
    – shawnngtq
    Jun 24, 2018 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.