1

I have a TP-Link MR3420 router with OpenWRT, and I can't forward port to a destination host in my LAN.

In firewall I have set like below:

config redirect
option name 'ssl'
option proto 'tcp'
option src 'wan'
option src_dip '109.241.232.66'
option src_dport '443'
option dest 'lan'
option dest_ip '192.168.1.104'
option dest_port '443'

What i do wrong ? Can you help me ?

What information I must provide for you to solve this problem?

I have static external IP: 109.241.232.66 and set DCP on WAN.

Everything works fine except port forwarding.

And besides port forwarding, I have to open it on the router in the Firewall - Traffic Rules section

0

Regarding to the official documentation from here: https://wiki.openwrt.org/doc/howto/port.forwarding your config section should be:

config 'redirect'
        option 'name' 'ssl'
        option 'src' 'wan'
        option 'proto' 'tcp'
        option 'src_dport' '443'
        option 'dest_ip' '192.168.1.104'
        option 'dest_port' '443'
        option 'target' 'DNAT'
        option 'dest' 'lan'

But please check, if OpenWRT allow to redirect https (tcp:443) traffic.

  • You mean In Firewall - Traffic Rules section ? – bulimaster Jun 25 '18 at 9:26
  • Correct your setting as I provided, restart firewall and check if it works. Check generally, in documentation :) – mariaczi Jun 25 '18 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.