1

I use Ubuntu 16.04 and want to upgrade.

root@desktop:/# lsb_release -a
LSB Version:    core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.4 LTS
Release:        16.04
Codename:       xenial

root@desktop:/# apt-get update
Hit:1 http://gb.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]                         
Hit:3 http://ppa.launchpad.net/hda-me/higan/ubuntu xenial InRelease                                                                                           
Get:4 http://gb.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]                                                                                   
Get:5 http://gb.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]                                                                     
Hit:6 http://archive.canonical.com/ubuntu xenial InRelease                         
Hit:7 http://archive.canonical.com xenial InRelease
Fetched 323 kB in 0s (482 kB/s)                   
Reading package lists... Done

root@desktop:/# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

root@desktop:/# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

root@desktop:/# do-release-upgrade
Checking for a new Ubuntu release
No new release found.

It thinks that it doesn't need to upgrade.

Earlier today I ran apt-get dist-upgrade and the output appeared to show that the upgrade worked. Here is /var/log/apt/history.log

Start-Date: 2018-06-25  14:09:40
Commandline: apt-get dist-upgrade
Requested-By: admin (1000)
Install: libqpdf21:amd64 (8.0.2-3~16.04.1, automatic), intel-microcode:amd64 (3.20180425.1~ubuntu0.16.04.1, automatic), iucode-tool:amd64 (1.5.1-1ubuntu0.1, automatic), linux-headers-4.4.0-128:amd64 (4.4.0-128.154, automatic), linux-headers-4.4.0-128-generic:amd64 (4.4.0-128.154, automatic), libqmi-glib5:amd64 (1.16.2-1ubuntu0.16.04.1, automatic), amd64-microcode:amd64 (3.20180524.1~ubuntu0.16.04.1, automatic), libwebpdemux1:amd64 (0.4.4-1, automatic), libllvm5.0:amd64 (1:5.0-3~16.04.1, automatic), linux-image-4.4.0-128-generic:amd64 (4.4.0-128.154, automatic), linux-signed-image-4.4.0-128-generic:amd64 (4.4.0-128.154, automatic), linux-image-extra-4.4.0-128-generic:amd64 (4.4.0-128.154, automatic), libdrm-common:amd64 (2.4.83-1~16.04.1, automatic)
Upgrade: perl-base:amd64 (5.22.1-9ubuntu0.3, 5.22.1-9ubuntu0.5), libqmi-proxy:amd64 (1.12.6-1, 1.16.2-1ubuntu0.16.04.1), libgcrypt20-dev:amd64 (1.6.5-2ubuntu0.4, 1.6.5-2ubuntu0.5), libimage-magick-perl:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), linux-headers-generic:amd64 (4.4.0.97.102, 4.4.0.128.134), libdrm-nouveau2:amd64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), linux-libc-dev:amd64 (4.4.0-127.153, 4.4.0-128.154), gnupg-agent:amd64 (2.1.11-6ubuntu2, 2.1.11-6ubuntu2.1), scdaemon:amd64 (2.1.11-6ubuntu2, 2.1.11-6ubuntu2.1), ruby2.3:amd64 (2.3.1-2~16.04.9, 2.3.1-2~16.04.10), libimage-magick-q16-perl:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), libegl1-mesa-dev:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.8-0ubuntu0~16.04.1), imagemagick:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), linux-image-generic:amd64 (4.4.0.97.102, 4.4.0.128.134), libmagickwand-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), linux-signed-image-generic:amd64 (4.4.0.97.102, 4.4.0.128.134), perl-modules-5.22:amd64 (5.22.1-9ubuntu0.3, 5.22.1-9ubuntu0.5), console-setup-linux:amd64 (1.108ubuntu15.3, 1.108ubuntu15.4), libxatracker2:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.8-0ubuntu0~16.04.1), console-setup:amd64 (1.108ubuntu15.3, 1.108ubuntu15.4), flashplugin-installer:amd64 (29.0.0.171ubuntu0.16.04.1, 30.0.0.113ubuntu0.16.04.1), libegl1-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.8-0ubuntu0~16.04.1), libmagic1:amd64 (1:5.25-2ubuntu1, 1:5.25-2ubuntu1.1), libgcrypt11-dev:amd64 (1.5.4-3+really1.6.5-2ubuntu0.4, 1.5.4-3+really1.6.5-2ubuntu0.5), linux-signed-generic:amd64 (4.4.0.97.102, 4.4.0.128.134), perl-doc:amd64 (5.22.1-9ubuntu0.3, 5.22.1-9ubuntu0.5), libgbm1:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.8-0ubuntu0~16.04.1), dirmngr:amd64 (2.1.11-6ubuntu2, 2.1.11-6ubuntu2.1), libperl5.22:amd64 (5.22.1-9ubuntu0.3, 5.22.1-9ubuntu0.5), libdrm-amdgpu1:amd64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), cups-filters:amd64 (1.8.3-2ubuntu3.1, 1.8.3-2ubuntu3.4), imagemagick-6.q16:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), libmagickcore-6.q16-2-extra:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), libruby2.3:amd64 (2.3.1-2~16.04.9, 2.3.1-2~16.04.10), firefox-locale-en:amd64 (60.0.1+build2-0ubuntu0.16.04.1, 60.0.2+build1-0ubuntu0.16.04.1), libwayland-egl1-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.8-0ubuntu0~16.04.1), libgcrypt20:amd64 (1.6.5-2ubuntu0.4, 1.6.5-2ubuntu0.5), gpgv:amd64 (1.4.20-1ubuntu3.1, 1.4.20-1ubuntu3.2), libmm-glib0:amd64 (1.4.12-1ubuntu1, 1.6.4-1ubuntu0.16.04.1), libdrm2:amd64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libwebkit2gtk-4.0-37:amd64 (2.18.5-0ubuntu0.16.04.1, 2.20.3-0ubuntu0.16.04.1), libgl1-mesa-dri:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.8-0ubuntu0~16.04.1), libmagickcore-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), keyboard-configuration:amd64 (1.108ubuntu15.3, 1.108ubuntu15.4), libvirt0:amd64 (1.3.1-1ubuntu10.23, 1.3.1-1ubuntu10.24), qpdf:amd64 (6.0.0-2, 8.0.2-3~16.04.1), gnupg2:amd64 (2.1.11-6ubuntu2, 2.1.11-6ubuntu2.1), cups-filters-core-drivers:amd64 (1.8.3-2ubuntu3.1, 1.8.3-2ubuntu3.4), file:amd64 (1:5.25-2ubuntu1, 1:5.25-2ubuntu1.1), libdrm-intel1:amd64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), firefox:amd64 (60.0.1+build2-0ubuntu0.16.04.1, 60.0.2+build1-0ubuntu0.16.04.1), perl:amd64 (5.22.1-9ubuntu0.3, 5.22.1-9ubuntu0.5), modemmanager:amd64 (1.4.12-1ubuntu1, 1.6.4-1ubuntu0.16.04.1), imagemagick-common:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), libmagick++-6.q16-5v5:amd64 (8:6.8.9.9-7ubuntu5.9, 8:6.8.9.9-7ubuntu5.11), libdrm-radeon1:amd64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), mesa-vdpau-drivers:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.8-0ubuntu0~16.04.1), gnupg:amd64 (1.4.20-1ubuntu3.1, 1.4.20-1ubuntu3.2), desktop-file-utils:amd64 (0.22-1ubuntu5.1, 0.22-1ubuntu5.2), libjavascriptcoregtk-4.0-18:amd64 (2.18.5-0ubuntu0.16.04.1, 2.20.3-0ubuntu0.16.04.1), libdrm-dev:amd64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), linux-generic:amd64 (4.4.0.97.102, 4.4.0.128.134), wireless-regdb:amd64 (2015.07.20-1ubuntu1, 2018.05.09-0ubuntu1~16.04.1), libwebkit2gtk-4.0-37-gtk2:amd64 (2.18.5-0ubuntu0.16.04.1, 2.20.3-0ubuntu0.16.04.1), gpgsm:amd64 (2.1.11-6ubuntu2, 2.1.11-6ubuntu2.1)
End-Date: 2018-06-25  14:12:54

Start-Date: 2018-06-25  14:16:01
Commandline: apt-get autoremove
Requested-By: admin (1000)
Remove: libqpdf17:amd64 (6.0.0-2), linux-headers-4.4.0-72-generic:amd64 (4.4.0-72.93), libllvm4.0:amd64 (1:4.0-1ubuntu1~16.04.2), linux-headers-4.4.0-72:amd64 (4.4.0-72.93), libgeoclue0:amd64 (0.12.99-4ubuntu1), linux-signed-image-4.4.0-72-generic:amd64 (4.4.0-72.93), linux-image-4.4.0-72-generic:amd64 (4.4.0-72.93), linux-image-extra-4.4.0-72-generic:amd64 (4.4.0-72.93)
End-Date: 2018-06-25  14:16:24

I then rebooted and lsb_release -a shows I am still running 16.04.

How do I upgrade?

1

I bet if you run grep '^Prompt=' /etc/update-manager/release-upgrades, you'll see this:

Prompt=lts

This means that you want to upgrade to the next long-term support release.

Even though Ubuntu 18.04 LTS was released almost two months ago (26 April 2018), do-release-upgrade doesn't see Ubuntu 18.04 LTS as the next LTS until about one month from now (26 July 2018), version 18.04.1.

Why this is done is explained in "Why is “No new release found” when upgrading from a LTS to the next?" on Ask Ubuntu.

How to Upgrade

The easiest way to upgrade to Ubuntu 18.04 LTS anyway is to run this as root:

do-release-upgrade -d

You could alternatively edit Prompt= in /etc/update-manager/release-upgrades to read

Prompt=normal

And then run as root:

do-release-upgrade

Additional Resources

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.