5

Recently, I have built a computer and I am trying to install Proxmox on my internal M2 Drives.

Relevant Hardware:

  • Samsung 960 EVO (X2)
  • Asus Z370-E

The initial plan was to put both the M2 drives in RAID0 and install Proxmox on that. However, the installation did not detect the M2 drives at all. I tried removing the RAID, but the drives were still not detected. I have also tried both Legacy and UEFI booting.

To further investigate, I tried to get the drives to recognize on other Linux distros. None of them would see the drives. However, I was successful in Windows seeing these drives.

Linux Distros I Have Tried:

  • Ubunut
  • Lubuntu
  • Kali Linux
  • Proxmox
  • Clonezilla

At this point, I am thinking it a compatibility or BIOS related issue. However, I can't seem to figure this out.

Things I Have Tried:

  • Booting to Legacy and UEFI
  • Tried multiple Linux Dristros
  • Updating the BIOS to the latest firmware
  • Changing/Removing the RAID.
4

I have discovered the answer. Turning off "Intel Rapid Storage Technology" from the EZ Mode page in the BIOS allowed and then booting the Proxmox installer in Legacy mode allowed the installer to detect the NVMe drives.

After the drives were formatted to ZFS I reinstalled Proxmox over UEFI. Everything is now booting successfuly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.